Bug 741498 - AltGr-up and AltGr-down keyboard shortcuts in the editor to navigate to the next and previous strings do not work
AltGr-up and AltGr-down keyboard shortcuts in the editor to navigate to the n...
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.3
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 23:43 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 02:07:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2011-09-26 23:43:22 EDT
Description of problem:

While using the Web Editor, the Alt+up and Alt+down keyboard shortcuts to move to the next and previous strings respectively currently do not work.


How reproducible:


Steps to Reproduce:

1. Go to translate.zanata.org
2. Log-in and select a project to work on
3. Open a file to translate in the Editor
4. Focus on an entry to make it editable
5. Press Alt+Up to move to the next entry or Press Alt+Down to move to the previous entry

  
Actual results:

The focus stays on the current entry

Expected results:

The focus should move in the direction as per the shortcuts used

Additional info:

1. Also replicated for the current development version - 1.4
2. Tested on entries which are not the first or last entries on the page
Comment 1 Runa Bhattacharjee 2011-09-28 06:05:47 EDT
Correction:

These shortcuts do not work with the Right Alt key only, for some browser versions.
Comment 2 sandeep shedmake 2011-09-28 06:12:20 EDT
Navigation to previous and next translation unit(s) works for me in translation editor when using Alt_L modifier (tested with firefox-6.0.2-1.fc15.x86_64 & chromium 13.0.782.215-1.fc15.x86_64). 

Note: above behaviour doesn't work with Alt_R modifier.
Comment 3 Nilamdyuti 2011-09-28 06:53:07 EDT
Navigation to previous and next entry works works for me in translation editor only while using Alt_L modifier. With Alt_R it doesn't work. 

Browser: firefox-3.6.20-2.el6_1.x86_64

OS: el6.x86_64
Comment 4 Runa Bhattacharjee 2011-09-28 22:12:18 EDT
One user has mentioned that he could not replicate the bug using firefox-6.0.2-1.fc15.x86_64, although another user (comment #2) could replicate with the same version.
Comment 5 sandeep shedmake 2011-09-29 00:09:56 EDT
From Comment 2 and Comment 3, 
required behaviour of navigation to next and previous translation unit(s) works with Alt_L (i.e. Alt left) modifier, and hence expected results are obtained.

From Comment 1, Comment 2 and Comment 3,
required behaviour of navigation to next and previous translation unit(s) doesn't work with Alt_R (i.e. Alt right) modifier, and hence expected results are not obtained.
Comment 6 Ding-Yi Chen 2011-09-29 01:18:55 EDT
It maybe the keyboard layout problem.

sandeep, what's your keyboard layout? Does the Right Alt is shown as "AltGr"?

Or please type following in a terminal window:
1. xev
2. And press following:
   alt_L-UP
   alt_R-UP
3. close xev
4. Paste the result, which should somewhat looks like:

KeyPress event, serial 33, synthetic NO, window 0x5800001,
    root 0xb1, subw 0x0, time 24921477, (144,19), root:(146,109),
    state 0x0, keycode 108 (keysym 0xffea, Alt_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x5800001,
    root 0xb1, subw 0x0, time 24921596, (144,19), root:(146,109),
    state 0x8, keycode 111 (keysym 0xff52, Up), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x5800001,
    root 0xb1, subw 0x0, time 24921651, (144,19), root:(146,109),
    state 0x8, keycode 111 (keysym 0xff52, Up), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x5800001,
    root 0xb1, subw 0x0, time 24921785, (144,19), root:(146,109),
    state 0x8, keycode 116 (keysym 0xff54, Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x5800001,
    root 0xb1, subw 0x0, time 24921872, (144,19), root:(146,109),
    state 0x8, keycode 116 (keysym 0xff54, Down), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 7 sandeep shedmake 2011-09-29 02:09:12 EDT
(In reply to comment #6)
> It maybe the keyboard layout problem.
> 

Yes. I agree with you.

> sandeep, what's your keyboard layout? Does the Right Alt is shown as "AltGr"?
> 


Yes, Right Alt is shown as "AltGr".

This has been done to add "Rupee" currency sign to key bearing numeral '4'; and key to choose 3rd level was 'Right Alt'.


xev output:
============
KeyPress event, serial 32, synthetic NO, window 0x3600001,
	root 0xb8, subw 0x0, time 636197, (790,272), root:(791,361),
	state 0x0, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
	XKeysymToKeycode returns keycode: 92
	XLookupString gives 0 bytes: 
	XmbLookupString gives 0 bytes: 
	XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3600001,
	root 0xb8, subw 0x0, time 636335, (790,272), root:(791,361),
	state 0x80, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
	XKeysymToKeycode returns keycode: 92
	XLookupString gives 0 bytes: 
	XFilterEvent returns: False


Therefore, required behaviour of navigation to next and previous translation unit(s) works with Alt_R (i.e. Alt right) modifier, and hence expected results are obtained.

This concludes that this bug can't be reproduced henceforth.
Comment 8 Runa Bhattacharjee 2011-09-29 23:40:25 EDT
Confirmed that the Right Alt+up/down works if the 'Indian Keyboard with Rupee Sign' is disabled. Unfortunately, for Indian users this won't be feasible. With the plans of using Alt_Gr on a much larger scale for various Indian input methods (also to be included in ibus), this particular shortcut may have to be explicitly restricted to the Left Alt.
Comment 9 Ding-Yi Chen 2011-09-29 23:58:46 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > It maybe the keyboard layout problem.
> > 
> 
> Yes. I agree with you.
> 
> > sandeep, what's your keyboard layout? Does the Right Alt is shown as "AltGr"?
> > 
> 
> 
> Yes, Right Alt is shown as "AltGr".
> 
> This has been done to add "Rupee" currency sign to key bearing numeral '4'; and
> key to choose 3rd level was 'Right Alt'.
> 
> 
> xev output:
> ============
> KeyPress event, serial 32, synthetic NO, window 0x3600001,
>  root 0xb8, subw 0x0, time 636197, (790,272), root:(791,361),
>  state 0x0, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
>  XKeysymToKeycode returns keycode: 92
>  XLookupString gives 0 bytes: 
>  XmbLookupString gives 0 bytes: 
>  XFilterEvent returns: False
> 
> KeyRelease event, serial 32, synthetic NO, window 0x3600001,
>  root 0xb8, subw 0x0, time 636335, (790,272), root:(791,361),
>  state 0x80, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
>  XKeysymToKeycode returns keycode: 92
>  XLookupString gives 0 bytes: 
>  XFilterEvent returns: False
> 
> 
> Therefore, required behaviour of navigation to next and previous translation
> unit(s) works with Alt_R (i.e. Alt right) modifier, and hence expected results
> are obtained.
> 
> This concludes that this bug can't be reproduced henceforth.

Just as I suspected,

"Normal" Alt produce 0x8, while AltGr produce 0x80

Thus Alt-Up is not the same with AltGr-Up

BTW,
does AltGr-Up, AltGr-Down, AltGr-PgUp, AltGr-PgDn clash with your input method or keyboard layout?
Comment 10 Sean Flanigan 2011-09-30 00:06:48 EDT
So, is this a request to enable AltGr-Up/Down/PgUp/PgDn, or to avoid them, and keep them free for input methods?  Do we need to do anything?
Comment 11 Runa Bhattacharjee 2011-09-30 00:34:27 EDT
Ideally to avoid Alt_Gr. At present it conflicts with the 'Indian Keyboard with the Rupee Sign'. However, going forward it will conflict with IBus as well, due to the Enhanced Inscript keyboards for the Indian languages with heavy usage of Alt_Gr. These are currently in the testing phase.

https://fedorahosted.org/inscript2/
Comment 12 Ding-Yi Chen 2011-09-30 02:07:48 EDT
As modifier AltGr might clash when inputting Indic, this bug will be closed as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.