Bug 74151 - gdmphotosetup crashes running under KDE (when clicking browse)
gdmphotosetup crashes running under KDE (when clicking browse)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Mike McLean
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-09-16 20:10 EDT by James Turner
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 19:28:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2002-09-16 20:10:15 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
Running gdmphotosetup, after clicking "OK" on the message that photo browsing 
isn't enabled by the administrator, click Browse. Under GNOME, the file 
selection window appeared but didn't respond to mouse/keyboard. Moving it 
aside, the OK/Cancel buttons in the main gdmphotosetup window still worked and 
could be used to quit the application. Under KDE, the program crashes with 
signal 11 when the Browse button is pressed. 
 
Version-Release number of selected component (if applicable): 
gdm-2.4.0.7-4 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
1. Run gdmphotosetup 
2. Click "OK" on the message that photos havn't been set up yet. 
3. Click "Browse" to try to choose a photo. 
 
Actual Results:  Program crashes or goes wrong (see description above) 
 
Expected Results:  You pick your photo, and it appears in the gdm login 
screen. (assuming configured by administrator) 
 
Additional info: 
 
None
Comment 1 Marius Andreiana 2002-09-23 03:43:51 EDT
The bug with file selection being non-responsive was fixed ( there was another
bug here with it ), get the latest gdm from rawhide.

Don't know about crashing in KDE though
Comment 2 Havoc Pennington 2002-09-25 15:21:13 EDT
The unresponsiveness should indeed be fixed. will check the KDE issue.
Comment 3 Owen Taylor 2003-01-16 16:18:52 EST
Taking gdm target/blockers.
Comment 4 Owen Taylor 2003-01-16 19:28:33 EST
Works for me with current packages, I'll assume it has been fixed.

Note You need to log in before you can comment on or make changes to this bug.