Bug 74154 - xmms fails to load files after upgrade from RH 7.3 version
xmms fails to load files after upgrade from RH 7.3 version
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: xmms (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-16 20:54 EDT by James Turner
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-28 21:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2002-09-16 20:54:58 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
Click the eject button and choose a file (MP3). The track name doesn't appear 
in the playlist, and it doesn't play. 
 
Version-Release number of selected component (if applicable): 
1.2.7-10 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Log on to Null as a user who had previously used xmms under Red Hat 7.3 but 
not since. 
2. Load xmms 
3. Attempt to play an MP3 
 
Actual Results:  Failed to load file 
 
Expected Results:  File loads and starts playing 
 
Additional info: 
 
This occurs with xmms-1.2.7-10, which looks like it still includes an MP3 
codec. I have not investigated applicability to other filetypes. Normal 
functionality can be restored by deleting the .xmms directory from the user's 
home folder, which might suggest some sort of incompatible change in one of 
the file formats used within it.
Comment 1 Mike A. Harris 2002-09-28 21:33:18 EDT
MP3 decoders have been removed from Red Hat Linux due to patent
issues.  The GPL license explicitly states that if any software
patents apply to code which is GPL licensed, and the owner of
the patent has not given royalty free unlimited redistribution
rights for GPL usage, that the GPL license terms can not be met,
and you cannot legally ship the software.

Note You need to log in before you can comment on or make changes to this bug.