Bug 74170 - XFS filesystem missing in RH kernel
XFS filesystem missing in RH kernel
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 04:43 EDT by Simon Matter
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-17 04:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2002-09-17 04:43:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
XFS filesystem support is still missing in the newest RedHat Linux kernel,
preventing everyone from upgrading a RedHat Linux installation with self
compiled, XFS enhanced kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to upgrade a RedHat 7.3 box where several filesystems have been migrated
to XFS via self compiled kernel
2.
3.
	

Actual Results:  It doesn't work.

Expected Results:  Would be very nice if the kernel supports XFS filesystems.

Additional info:

While this is certainly not a bug, consider the following:

Now that XFS made its way into the 2.5 linus kernel tree, it's only a question
of time that RedHat will include support for XFS in RedHat Linux. Therefore I'm
kindly asking RedHat to include experimental XFS support into their next release
in form of an XFS enhanced kernel. This will make life much easier for thousands
of RedHat Linux customers and users who already use their own, self compiled,
XFS enhanced kernels on RedHat Linux.

Thanks!
Comment 1 Arjan van de Ven 2002-09-17 04:52:23 EDT
I think you are misinformed; the XFS filesystem is not yet in any Linus released
2.5 kernel
Comment 2 Simon Matter 2002-09-17 05:32:56 EDT
Fortunately, Linus has merged XFS into his BitKeeper tree; it will thus show up
in 2.5.36 :)

http://lwn.net/Articles/9998/
Comment 3 Werner Maes 2002-10-02 08:32:59 EDT
Here we're also waiting for RedHat to include XFS support in their distributions.
As for now, we cannot upgrade...

Does RedHat think that XFS competes with ext3?

Kind regards
Comment 4 Michael Sinz 2002-10-03 07:31:24 EDT
Note that we really want to move to RedHat 8.0 but will need to spend a lot of
effort in doing so as all of our major systems are running XFS as the filesystem.

I wonder why RedHat does not support XFS.  Most other distributions already do
support it.  RedHat included ext3 before it was part of the kernel source tree,
so this is not a request that goes against policy (unless that was against policy).

XFS has proven itself to us due to its ability to handle large numbers of files
in a filesystem and the performance of that filesystem.  The imap server runs
significantly better with XFS than ext3 or ext2 (or BSD UFS - one of the reasons
we are moving to Linux is XFS).  In fact, in addition to the performance being
as good as it is, XFS did not suffer from i-node limitations that we get in all
of the other filesystems we tried.  Plus the ability to recover from a
unexpected crash/reboot has proven to be very robust in our test labs.
Comment 5 Arjan van de Ven 2002-10-03 08:20:18 EDT
XFS used to be a support nightmare (until VERY VERY recently when Linus merged
it into 2.5)

EXT3 did not form such a nightmare since the on-disk format is compatible with
ext2, eg it didn't introduce on-disk layout incompatibilities with Linus' kernel.

Note You need to log in before you can comment on or make changes to this bug.