Bug 74172 - scroll_to_cell bug
Summary: scroll_to_cell bug
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk2   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-17 10:52 UTC by Tim Waugh
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 18:26:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Glade file (3.27 KB, text/plain)
2002-09-17 10:53 UTC, Tim Waugh
no flags Details
Python file (906 bytes, text/plain)
2002-09-17 10:53 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2002-09-17 10:52:28 UTC
Description of Problem: 
Sometimes scroll_to_cell doesn't scroll where I tell it to. 
 
Version-Release number of selected component (if applicable): 
gtk2-2.0.6-8 
pygtk2-1.99.12-7 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
See attached testcase 
1. python gtk2bug.py 
2. Click 'Forward' 
3. Inspect treeview 
 
Actual Results: 
Scrolled to near the beginning. 
 
Expected Results: 
Scrolled to keep item 150 centred. 
 
Additional Information: 
Recompiling gtk2 without -O2 makes the problem go away, as does inserting 
  while gtk.events_pending (): 
    gtk.mainiteration () 
in the callback function.

Comment 1 Tim Waugh 2002-09-17 10:53:06 UTC
Created attachment 76364 [details]
Glade file

Comment 2 Tim Waugh 2002-09-17 10:53:36 UTC
Created attachment 76365 [details]
Python file

Comment 3 Owen Taylor 2002-11-01 02:11:08 UTC
Probably fixed in current GNOME CVS; I'll be putting a 2.1.x snapshot
into the tree as soon as that is API frozen.


Comment 4 Owen Taylor 2003-01-14 20:58:32 UTC
Does this still happen with gtk2-2.2.0?

Reassigning to Mr. TreeView

Comment 5 Tim Waugh 2003-01-16 13:54:06 UTC
Still broken in gtk2-2.2.0-3.

Comment 6 Matthias Clasen 2004-05-12 18:26:08 UTC
I can't reproduce this with gtk2-2.4.0-1



Note You need to log in before you can comment on or make changes to this bug.