Bug 74175 - IRQ conflict, by this DMA on drive unavailable
Summary: IRQ conflict, by this DMA on drive unavailable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-17 13:14 UTC by Denis Fedorishenko
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 02:27:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Denis Fedorishenko 2002-09-17 13:14:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020526

Description of problem:
SvrWks CSB5: IDE controller on PCI bus 00 dev 79
PCI: Device 00:0f.1 not available because of resource collisions
SvrWks CSB5: (ide_setup_pci_device:) Could not enable device.
Alan Cox says about some workaround, but i'm not know all details.
after this enabling DMA on hard drive impossible, this problem i see on many
systems. Alan Cox


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enable PnP OS in BIOS? On most default settings IRQ conflict.
2.
3.
	

Actual Results:  Device XX:XX.X not available because of resource collisions

hdparm -d 1 /dev/hdb

setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted


Additional info:

Comment 1 Colin Tinker 2002-10-13 16:38:18 UTC
I have this problem on 5 systems but it only applies to the cdrom.

Comment 2 Alan Cox 2003-06-08 02:27:35 UTC
The current errata kernels resolve this issue



Note You need to log in before you can comment on or make changes to this bug.