Bug 74181 - Wrong font under zh_CN locale
Wrong font under zh_CN locale
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: gtk2 (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 10:26 EDT by Xu Hao Qing
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-17 10:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Hao Qing 2002-09-17 10:26:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Under zh_CN locale, "sans" font is actually a serif font. I guest that's because
gtk2 uses a zh_CN font (zhongyi song, or simsun?) anywere, regardless whether a
character is an ascii letter or a chinese character.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose "Simplified Chinese" locale, and login gnome2 desktop
2.Select "Foot Menu(Hat Menu now :))->Preferences->Font. Font Preferences dialog
will run
3.Note that "Descktop font" is "Sans 12". now click on the button, now "Pick a
font" dialog will run. 
4.Now, look close the preview area, they are really serif, not sans.
	

Actual Results:  "sans" font is acturally serif

Expected Results:  All lattin alphabet(a-z, A-Z) is realy sans, even under zh_CN
locale

Additional info:

gtk1.2 use fontset to achieve the same effect I expect. :

style "gtk-default-zh-cn" {
       fontset = "-adobe-helvetica-medium-r-normal--16-*-*-*-*-*-iso8859-1,\
                  -*-*-medium-r-normal--16-*-*-*-*-*-gb2312.1980-0,*-r-*"
}
Comment 1 Owen Taylor 2002-09-18 14:35:54 EDT
We considered it more important to use the most legible Chinese font
we had available for Sans, and to maintain consistancy between the
Roman and Han portions, than to actually have a font that was 
sans-serif.

(We use "Sans" as the default UI font)
Comment 2 Xu Hao Qing 2002-09-19 01:43:05 EDT
Hi. Just to offer some information.
Under windows, e.g. in outlook, you write down "abc$$$", where $$$ stands for 
three Chinese characters. If you apply "Songti"(simsun, a Chinese font name, 
it's serif) font to the string, the whole string, that is, both "abc" and "$$$" 
will be all "Songti". If you apply "MS Sans Serif" to the whole string, 
the "abc" will become "MS Sans Serif", while "$$$" will remain "Songti". The 
latter effect is good. 
<strong>
Actually, "abc"'s shapes in Chinese Songti font are ugly enough to drive users 
away, because, for now, not all interface strings are translated into Chinese.
</strong>
And even more, for developers, most of us write "abc" rather than "$$$" every 
day. I feel I need a good look "Sans" font when I write "abc", while when 
needed, I can input "$$$" between the "Sans" "abc".

Yes, a bit ambitous. Just some information.

Note You need to log in before you can comment on or make changes to this bug.