Bug 741817 - DispatchError: Can not reschedule step 'bootloader' from 'skipped' to 'requested'
DispatchError: Can not reschedule step 'bootloader' from 'skipped' to 'reques...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:22ab41917d860f2a7411474268d...
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-27 22:37 EDT by Adam Williamson
Modified: 2014-09-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-21 02:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-snRmF0 (405.09 KB, text/plain)
2011-09-27 22:38 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-09-27 22:37:58 EDT
abrt version: 2.0.5.980
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
product:        Fedora
reason:         DispatchError: Can not reschedule step 'bootloader' from 'skipped' to 'requested'
time:           Tue Sep 27 19:37:06 2011
version:        16

anaconda-tb-snRmF0: Text file, 414812 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 98, in _reschedule
:    self.namesched(to_sched)))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 119, in request
:    return self._reschedule(self.SCHED_REQUESTED, current_step)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 297, in <lambda>
:    changes = map(lambda s: self.steps[s].request(self._current_step()), steps)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 297, in request_steps
:    changes = map(lambda s: self.steps[s].request(self._current_step()), steps)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/upgrade_bootloader_gui.py", line 47, in getNext
:    self.dispatch.request_steps("bootloader")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1199, in nextClicked
:    rc = self.currentWindow.getNext ()
:DispatchError: Can not reschedule step 'bootloader' from 'skipped' to 'requested'
Comment 1 Adam Williamson 2011-09-27 22:38:02 EDT
Created attachment 525247 [details]
File: anaconda-tb-snRmF0
Comment 2 Adam Williamson 2011-09-27 22:39:50 EDT
Just as a happy added bonus while we're establishing the extent to which EFI on F16 is screwed, this is what happens if you try and upgrade a (working) F15 / EFI system to F16 and select 'write new bootloader configuration' (the default). It crashes immediately on hitting 'Next'.
Comment 3 Adam Williamson 2011-09-27 22:40:19 EDT
worth considering for blocker status.
Comment 4 Adam Williamson 2011-09-27 22:41:19 EDT
oddly, I see a similar error in the log of a straight-through F16 / EFI install, but no crash. (such an install doesn't boot, but anaconda doesn't crash).
Comment 5 Adam Williamson 2011-09-29 05:44:38 EDT
discussed at 2011-09-28 go/no-go meeting, acting as a blocker review. agreed the likely number of people wanting to upgrade f15 efi installs to f16 beta is just too small to consider this a blocker, but we will likely take it as a final blocker, so proposing there.
Comment 6 Adam Williamson 2011-09-29 05:51:12 EDT
it was mentioned on #anaconda that this is likely due to some difference in how step transition gets called between fresh install and upgrade, or smth like that. some specific function was mentioned, but i forget the name.
Comment 7 Ales Kozumplik 2011-09-29 08:02:00 EDT
Hi Adam, can you please try http://akozumpl.fedorapeople.org/bz741817.img and see if the updates image fixes this problem?
Comment 8 Tim Flink 2011-10-03 12:56:19 EDT
Discussed in the 2011-09-30 blocker bug review meeting. Rejected as a blocker bug for Fedora 16 final because it doesn't hit any of the release criteria.

However, this would likely hit any ks installation w/ interactive package selection and can't be fixed post-release. Therefore, accepted as NTH for Fedora 16 final.
Comment 9 Tim Flink 2011-10-03 12:59:03 EDT
(In reply to comment #8)
> Discussed in the 2011-09-30 blocker bug review meeting. Rejected as a blocker
> bug for Fedora 16 final because it doesn't hit any of the release criteria.
> 
> However, this would likely hit any ks installation w/ interactive package
> selection and can't be fixed post-release. Therefore, accepted as NTH for
> Fedora 16 final.

Whoops, wrong tab. Ignore my last comment.

Discussed in the 2011-09-30 blocker bug review meeting. Accepted as a Fedora 16 final blocker as it violates the following final release criterion [1]:

The installer must boot and run on systems using EFI other than Apple Macs 

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 10 Ales Kozumplik 2011-10-04 04:43:57 EDT
Fixed by 0fb13ed02574a33c09f8a6cd50b1d06e2935b1d1 (562f181d06bf171b54792c983073195afb7b981e on master).
Comment 11 Adam Williamson 2011-10-21 02:39:16 EDT
confirmed fixed in Final TC2: i can successfully upgrade an EFI install of F15 to F16. yay.

Note You need to log in before you can comment on or make changes to this bug.