Bug 74183 - BFD 2.11.93.0.2 20020207 assertion fail elf-strtab.c:262
BFD 2.11.93.0.2 20020207 assertion fail elf-strtab.c:262
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 10:50 EDT by Sysoltsev Slawa
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 18:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sysoltsev Slawa 2002-09-17 10:50:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I've got an assertion fail in ld. Looks like it doesn't impact anything but may 
be you should to know about it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Files you need:
ONE.c:
int ONE() { printf ("In ONE\n"); }
TWO.c:
int TWO() { printf ("In TWO\n"); }
main.c:
int main()
{
    ONE();
    TWO();
}

2. gcc -c ONE.c TWO.c
3. ar -crs libONE.a ONE.o
4. gcc -shared TWO.o -o libTWO.so
5. gcc main.c -L. -Wl,-rpath=. -lTWO -Wl,-Bstatic,-lONE
6. ./a.out


Actual Results:  >gcc -c ONE.c TWO.c
>ar -crs libONE.a ONE.o
>gcc -shared TWO.o -o libTWO.so
>gcc main.c -L. -Wl,-rpath=. -lTWO -Wl,-Bstatic,-lONE
/usr/bin/ld: BFD 2.11.93.0.2 20020207 assertion fail elf-strtab.c:262
>./a.out
In ONE
In TWO


Expected Results:  >gcc -c ONE.c TWO.c
>ar -crs libONE.a ONE.o
>gcc -shared TWO.o -o libTWO.so
>gcc main.c -L. -Wl,-rpath=. -lTWO -Wl,-Bstatic,-lONE
>./a.out
In ONE
In TWO

Additional info: 
asertion fails because refcount to 'llseek' isn't zero.
Why, I don't know.
Comment 1 Oleg Goldshmidt 2002-10-04 17:17:13 EDT
The same assertion fails with

$ gcc -g -pg hello_world.c -lc_p
/usr/bin/ld: BFD 2.11.93.0.2 20020207 assertion fail elf-strtab.c:262

where hello_world.c is just what it says. Cf. also

https://listman.redhat.com/pipermail/enigma-list/2001-December/004751.html

Tested with RH7.3,

gcc-2.96-112
binutils-2.11.93.0.2-11
glibc-2.2.5-39
glibc-profile-2.2.5-39
Linux 2.4.18-10
Comment 2 Alan Cox 2002-12-15 18:03:49 EST
Works for me in 8.0

Note You need to log in before you can comment on or make changes to this bug.