Bug 742013 - sub-mgr translations not showing up in firstboot
sub-mgr translations not showing up in firstboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62 748554
  Show dependency treegraph
 
Reported: 2011-09-28 15:12 EDT by Chris Duryee
Modified: 2011-12-06 12:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of untranslated strings (105.65 KB, image/png)
2011-09-28 15:12 EDT, Chris Duryee
no flags Details
"You must enter a login." in not translated when triggered from firstboot (142.45 KB, image/png)
2011-10-14 17:17 EDT, John Sefler
no flags Details
wrong user/pass (165.27 KB, image/png)
2011-10-18 16:30 EDT, J.C. Molet
no flags Details
error translated (152.56 KB, image/png)
2011-10-19 16:50 EDT, J.C. Molet
no flags Details

  None (edit)
Description Chris Duryee 2011-09-28 15:12:18 EDT
Created attachment 525388 [details]
screenshot of untranslated strings

Description of problem:

If you run firstboot with a non-english translation (for example, de_DE), a number of strings do not show up as translated (see screenshot).

Version-Release number of selected component (if applicable):

0.96.12


How reproducible: every time


Steps to Reproduce:
1. LANG=de_DE firstboot
2.
3.
Comment 1 Chris Duryee 2011-10-03 16:10:56 EDT
master ce3be35bab00370a1cdd8d2b28c52382afa804d4 0.97.2+
RHEL6.2 01185c524dd47c3f13d4d56ddb23d0805a948090 0.97.13+
Comment 4 John Sefler 2011-10-14 17:17:21 EDT
Created attachment 528279 [details]
"You must enter a login." in not translated when triggered from firstboot

[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-0.96.15-1.git.2.6c0ad28.el6.x86_64

Comparing this LANG=de_DE screenshot of firstboot registration we happily see many more words are translated; unfortunately not all.  See screenshot of untranslated string "You must enter a login."

Moving back to NEW/FailsQA
Comment 5 Adrian Likins 2011-10-18 14:15:16 EDT
commit 0e69b129e0056dceb7d2689d925316a0d9f1dc7c
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Oct 18 12:12:43 2011 -0400

    742013: Fix for translations in firstboot
    
    Set the _ method to use ldgettext with "rhsm" domain
    instead of "firstboot". This fixes an issue with de_DE
    not finding translations for the registration dialog
    error messages. It also seems to fix the title message
    not being translated in firstboot.
Comment 6 J.C. Molet 2011-10-18 16:30:16 EDT
Created attachment 528884 [details]
wrong user/pass

When entering an incorrect user name and password when registering the error dialog for that is only partially translated (see screenshot).

This is working in normal subscription-manager-gui outside of firstboot.

Tested with 

subscription-manager-firstboot-0.96.15-1.git.9.0e69b12.el6.x86_64
subscription-manager-gnome-0.96.15-1.git.9.0e69b12.el6.x86_64
Comment 7 Adrian Likins 2011-10-19 11:20:46 EDT
commit 19f6e9958bdca398503e13bdfdc4badd3cce6c2c
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Oct 18 16:47:58 2011 -0400

    742013: more fixes for translations in firstboot
    
    firstboot is resetting textdomain, so set it
    in the modules we are pulling strings from
Comment 8 J.C. Molet 2011-10-19 16:50:32 EDT
Created attachment 529102 [details]
error translated

The error is now translated.  See screenshot


python-rhsm-0.96.14-1.git.1.0e23383.el6.noarch
subscription-manager-firstboot-0.96.16-1.git.0.8d1c34f.el6.x86_64
subscription-manager-0.96.16-1.git.0.8d1c34f.el6.x86_64
subscription-manager-gnome-0.96.16-1.git.0.8d1c34f.el6.x86_64

Marking VERIFIED.
Comment 9 errata-xmlrpc 2011-12-06 12:25:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.