Bug 74202 - gnome_proc_bar_construct API broken -- last argument changed
gnome_proc_bar_construct API broken -- last argument changed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 16:03 EDT by Julian Missig
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 16:42:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Missig 2002-09-17 16:03:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

Description of problem:
in libgnomeui/gnome-procbar.h, the last argument to gnome_proc_bar_construct has
changed. While the type it accepts now is the type it certainly *should* be
accepting, this fix breaks things like gnomemm.
http://bugzilla.gnome.org/show_bug.cgi?id=93434 is the appropriate gnomemm bug.
If gnomemm changes, then it will be broken with all the "official" releases of
gnome-libs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat null's gnome-libs
2. Download gnomemm
3. Attempt to compile
	

Actual Results:  gnomemm fails to compile due to API incompatibilities

Expected Results:  gnomemm should compile and work

Additional info:
Comment 1 Havoc Pennington 2002-09-17 16:22:05 EDT
I'm pretty sure we have not patched this. I can't imagine why we would have,
and don't see a patch in the RPM.

According to CVS, this function prototype was never changed in CVS, it has always 
been the way it is in CVS. Our package is indeed different though.

Basically, no idea. Our gnome-libs is in "never touch it again" mode for the
most part...
Comment 2 Havoc Pennington 2003-01-07 16:42:54 EST
Well, I guess this shipped in 8.0. I'm inclined to not touch it; 
changing it now just adds more special cases to deal with.

Note You need to log in before you can comment on or make changes to this bug.