Bug 742027 - Certificate status does not account for rhn classic
Certificate status does not account for rhn classic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: John Sefler
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-28 16:00 EDT by J.C. Molet
Modified: 2011-12-06 12:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Despite the red installed product certs, the overall Certificate Status is GREEN when registered to RHN Classic. (63.67 KB, image/png)
2011-10-01 00:11 EDT, John Sefler
no flags Details

  None (edit)
Description J.C. Molet 2011-09-28 16:00:41 EDT
Description of problem:
It seems that bug 667991 was only partially fixed.  When you are registered to rhn classic your Certificate status icon in the upper left corner of subscription-manager-gui is still RED, and the system fact 'system.entitlements_valid' is False. 

According to bug 667991 subscription manager should think it is fully compliant whenever it is registered to rhn classic.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.11-1.git.14.21c378d.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.14.21c378d.el6.x86_64
python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.14.21c378d.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.  register to rhn classic (or touch /etc/sysconfig/rhn/systemid )
2.  Start subscription-manager-gui
3.  Look at the system facts
  
Actual results:
 - The certificate status icon is RED.
 - fact system.entitlements_valid is False

Expected results:
 - The certificate status icon is GREEN. (and the message next to it references rhn_classic)
 - fact system.entitlements_valid is True

Additional info:
Comment 1 Chris Duryee 2011-09-30 13:27:47 EDT
RHEL6.2 0fdd5b9 0.96.13+
master f2fc5b6 0.97.2+
Comment 3 John Sefler 2011-10-01 00:11:10 EDT
Created attachment 525856 [details]
Despite the red installed product certs, the overall Certificate Status is GREEN when registered to RHN Classic.

Verifying version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager 
subscription-manager-0.96.11-1.git.21.0fdd5b9.el6.x86_64


[root@jsefler-onprem-62server ~]# touch /etc/sysconfig/rhn/systemid
[root@jsefler-onprem-62server ~]# subscription-manager list --installed | grep Status
    Installed Product Status
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed    

[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: True


VERIFIED...
 - despite all my non-subscribed products installed, my system.entitlements_valid fact is True
 - the attached screenshot shows the overall Certificate Status is GREEN despite the RED installed products.
 - the Certificate Status message in the gui is "This system is registered to RHN Classic"
Comment 4 errata-xmlrpc 2011-12-06 12:25:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.