Bug 742042 - anaconda should ensure the correct bootloader (grub-efi or grub2) is installed on upgrade from F15, and remove grub
anaconda should ensure the correct bootloader (grub-efi or grub2) is installe...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 743376
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-28 16:42 EDT by Keiran Smith
Modified: 2011-10-13 00:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-16.21-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 00:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keiran Smith 2011-09-28 16:42:43 EDT
Description of problem:
When running a yum Upgrade Grub has a package conflict with an older version


Version-Release number of selected component (if applicable):
grub2-1.99-6.fc16.x86_64

How reproducible:
All the time

Steps to Reproduce:
1. Run command yum upgrade -y
  
Actual results:
Error: grub conflicts with 1:grub2-1.99-6.fc16.x86_64
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
1:grub-0.97-77.fc16.x86_64 has installed conflicts grub2: 1:grub2-1.99-6.fc16.x86_64
perl-Module-CoreList-2.50-160.fc15.noarch has missing requires of perl = ('4', '5.12.4', '160.fc15')

Expected results:
Upgrade should sucesfully complete
Comment 1 Robert Lightfoot 2011-09-30 08:12:16 EDT
Occurs in Testing of FC16.i386-Beta.RC4
Comment 2 Robert Lightfoot 2011-09-30 08:18:05 EDT
http://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria  

Criteria 9 - "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria "
Comment 3 Robert Lightfoot 2011-09-30 14:56:36 EDT
Occurs in Testing of FC16.x86_64-Beta.RC4 also
Comment 4 Keiran Smith 2011-09-30 19:07:33 EDT
It seems to be caused by the upgrade process leaving a copy of the original GRUB bootloader. Should we not just upgrade the grub package for F16 to be equal to the GRUB2 release currently in use in F16. If we do that it doesnt mean we need to drop support for older grub versions by having a grub-legacy package also but thats just a thought.
Comment 5 Adam Williamson 2011-10-03 11:58:04 EDT
upgrading via yum is not supported, and beta is already approved: beta blockers can't be proposed after beta release is approved.
Comment 6 Keiran Smith 2011-10-03 12:13:59 EDT
Adam,
  I had upgraded using the DVD. This is when package updates are available.
Comment 7 Adam Williamson 2011-10-03 23:57:47 EDT
are you sure grub2 got installed as part of the upgrade? nothing requires it. though i suppose if anaconda refreshes the 'base' package set as part of upgrade...
Comment 8 Keiran Smith 2011-10-04 01:27:35 EDT
Yes GRUB2 definitely installed as part of my upgrade.
Comment 9 Adam Williamson 2011-10-04 13:56:21 EDT
updating to summary. If we confirm this as described it's probably a final blocker, as upgraded systems should be able to run further updates without yum complaints about conflicting packages. Consider this bug to cover the whole issue of what should happen with grub and grub2 packages on a system upgraded from F15 to F16.
Comment 10 Adam Williamson 2011-10-04 14:38:38 EDT
Updating summary again: let's make this the bug for ensuring anaconda has the right logic on upgrade from F15 to F16.

When handling an upgrade from F15 to F16, anaconda should ensure that either grub-efi or grub2 gets installed, depending on whether it's an EFI or BIOS installation that's being updated: pjones says this is a one-liner that is already on the ML for review. (This obviously depends on the existence of grub-efi, so let's depend on that bug).

It should also remove the 'grub' package to ensure it doesn't cause any problems, especially if that package is still going to conflict with grub2. This is, I believe, not yet implemented, and the cause of this bug as originally filed.
Comment 11 Adam Williamson 2011-10-07 13:20:38 EDT
Discussed at the 2011-10-07 blocker review meeting. Accepted as a blocker per criterion "The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria" due to the impact originally reported in Beta (post-upgrade yum operations complain about the grub2/grub conflict).
Comment 12 Fedora Update System 2011-10-11 14:35:19 EDT
anaconda-16.21-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.21-1.fc16
Comment 13 Fedora Update System 2011-10-13 00:37:57 EDT
anaconda-16.21-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.