Bug 742123 - DispatchError: Can not reschedule step 'group-selection' from 'requested' to 'skipped'
Summary: DispatchError: Can not reschedule step 'group-selection' from 'requested' to ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 16
Hardware: i686 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:eeaa18f71dc7fa9cbd99fae144e...
Keywords:
Depends On:
Blocks: F16-accepted, F16FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-09-29 07:37 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
8 users (show)

Fixed In Version: anaconda-16.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 01:47:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-ASIeC6 (424.02 KB, text/plain)
2011-09-29 07:37 UTC, Tao Wu
no flags Details

Description Tao Wu 2011-09-29 07:37:27 UTC
libreport version: 2.0.5.982
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc6.git0.3.fc16.i686
product:        Fedora
reason:         DispatchError: Can not reschedule step 'group-selection' from 'requested' to 'skipped'
time:           Thu Sep 29 03:36:33 2011
version:        16-Beta

anaconda-tb-ASIeC6: Text file, 434199 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.20 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 98, in _reschedule
:    self.namesched(to_sched)))
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 155, in skip
:    return self._reschedule(self.SCHED_SKIPPED, current_step)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in <lambda>
:    changes = map(lambda s: self.steps[s].skip(self._current_step()), steps)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in skip_steps
:    changes = map(lambda s: self.steps[s].skip(self._current_step()), steps)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/task_gui.py", line 510, in getNext
:    self.dispatch.skip_steps("group-selection")
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1199, in nextClicked
:    rc = self.currentWindow.getNext ()
:DispatchError: Can not reschedule step 'group-selection' from 'requested' to 'skipped'

Comment 1 Tao Wu 2011-09-29 07:37:35 UTC
Created attachment 525471 [details]
File: anaconda-tb-ASIeC6

Comment 2 Ales Kozumplik 2011-09-29 12:39:39 UTC
I can reproduce this.

1) use kickstart without a %packages section
2) on the task selection screen click 'customize later' and then 'next'.

Comment 3 Ales Kozumplik 2011-09-29 13:41:56 UTC
Patch awaiting review: https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00229.html

Comment 4 Tim Flink 2011-10-03 16:57:33 UTC
Discussed in the 2011-09-30 blocker bug review meeting. Rejected as a blocker
bug for Fedora 16 final because it doesn't hit any of the release criteria.

However, this would likely hit any ks installation w/ interactive package
selection and can't be fixed post-release. Therefore, accepted as NTH for
Fedora 16 final.

Comment 5 Ales Kozumplik 2011-10-04 08:44:56 UTC
Fixed by 80a1105b1bac1dba988fcd0e4d3f695c42e1145d (8471903bd1dbfb6b16096f1bf0e7bbacb6b9bdfe on master).

Comment 6 Adam Williamson 2011-11-03 01:47:31 UTC
This should be fixed by now, closing. Please re-open if it still occurs in 16 Final.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.