Bug 74232 - [RFE] up2date downloaded rpms have 'wrong' timestamp
[RFE] up2date downloaded rpms have 'wrong' timestamp
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 08:50 EDT by Marcel Mol
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-06 18:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Mol 2002-09-18 08:50:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020911

Description of problem:
Downloading rpms from the rhn.redhat.com channels gives you a tar file with the
requested packages. After unpacking the tar file the timestamp of the
rpm-packages seems to be the actual creation time of the rpm. 
When using up2date to download an rpm it will get the download time as the
timestamp. 
I'd like to file an enhancement request so that up2date also sets the 'correct'
timestamp.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.got http://rhn.redhat.com, select the null channel and download a rpm. 
  that is newer thatn you already have on your system.
2.unpack the downloadad tar file and notice the timestamp of the rpm.
3.Download the same rpm using up2date.
4. compare the timestamps of both versions of the rpm and notice the difference.
	

Actual Results:  Using the website you get for example 

   -rw-r--r--    1 marcel   marcel   13720818 Sep  5 00:35     
kernel-2.4.18-14.i686.rpm   

Using up2date you get for example                   

   -rw-r--r--    1 marcel   marcel   13720818 Sep  17 16:35
kernel-2.4.18-14.i686.rpm                      

Expected Results:  The same timestamps for both versions

Additional info:
Comment 1 Adrian Likins 2002-10-01 17:37:45 EDT
I'll leave this as an RFE. I don't think I understand why the
timestamps on the files matter though.

Note You need to log in before you can comment on or make changes to this bug.