Bug 742339 - useradd -Z broken
useradd -Z broken
Status: CLOSED DUPLICATE of bug 701355
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 15:00 EDT by Dominick Grift
Modified: 2011-11-10 04:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-10 04:17:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2011-09-29 15:00:12 EDT
Description of problem:
When i run useradd -Z staff_u domg472:

/usr/sbin/semanage: Linux User domg472 does not exist
useradd: warning: the user name domg472 to staff_u SELinux user mapping failed.

I end up without a Linux user, but with a home dir and mail spool for that to be created Linux user.

Version-Release number of selected component (if applicable):
libsemanage-python-2.1.2-1.fc16.x86_64
libsemanage-2.1.2-1.fc16.x86_64
shadow-utils-4.1.4.3-7.fc16.x86_64

How reproducible:
useradd -Z staff_u joe

Steps to Reproduce:
1. useradd -Z staff_u joe
2.
3.
  
Actual results:
/usr/sbin/semanage: Linux User joe does not exist
useradd: warning: the user name joe to staff_u SELinux user mapping failed.
Comment 1 Miroslav Grepl 2011-09-30 02:22:20 EDT
It looks like an useradd issue.
Comment 2 Daniel Walsh 2011-09-30 10:45:00 EDT
Yes I know this issue was fixed somewhere.  Basically libsemanage is verifying the user exists before the user is added to /etc/passwd.
Comment 3 Peter Vrabec 2011-11-10 04:17:02 EST

*** This bug has been marked as a duplicate of bug 701355 ***

Note You need to log in before you can comment on or make changes to this bug.