Bug 74234 - Panic during boot
Panic during boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 09:56 EDT by Kevin Walton
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Walton 2002-09-18 09:56:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; .NET CLR 1.0.3705)

Description of problem:
See service request 213705:

Installing 7.3 onto a Dell Latitude LS laptop.	Instalation goes seemlessly, 
installed 3 times:

First - Workstation Install, heavily customed
Second - Workstation Install, totally default
Thurs - Laptop install, EXT2 FS for all partitions, block check for all 
partitions everything else totally default - block checks went fine.

Every time - Reboots, loads the kernel, then fails to start init.  Errors from 
the third boot:

==

Partition Check:
 hda:hda: status time out: status=0xd0 { busy }
hda: DMA disabled
hda: drive not ready for command
ide0: reset timed-out
end_request: I/O error, dev 03:00 (hda), sector 2
...
net4: ...
end_request: I/O error, dev 03:02 (hda), sector 2
EXT2-fs: unable to read superblock
isofs_read_super: bread failed, dev=03:02, iso_blknum=16, block=32
Kernel panic: VFS: Unable to mount root fs on 03:02

==

Slightly different errors from the first 2 installs:

end_request: I/O error, dev 03:07 (hda), sector 2

EXT3-fs: unable to read superblock

error 22

==

Searching around suggested Power Managment issues - which I have all turned off 
in the BIOS, and Journel issues - I booted up rescue mode, tried to create a 
journel on each partition but they already existed.

As suggested by support I tried: 

linux text apm=off ide=nodma ide=noautotune at install time, and adding apm=off 
ide=nodma ide=noautotune at boot time to no effect on Redhat - these options 
did make Mandrake work though!

More info from a 4th EXT3 install with the options above:

A dump of as much of the relevant info as I could get coppied down:


PIIX4: not 100$ native mode: will probe irqs later
...

blk: queue ..., I/O limit ... (mask ...)
hda: set_drive_speed_status: status=0xd0 { busy }
hda status timeout
hda: drive not ready for command
...
hda: DMA disabled
hda: drive not ready for command
ide0: reset timed out
   
...

Mounting Root filesystem
end_request: I/O error, dev 03:06 (hda), sector 2
EXT3-fs unable to read superblock
mount error 22 mounting ext3
pivotroot: ... failed: 2
Kernel panic: no init found ..

Hardware is a Dell Latitude LS H400ST with external IDE CD drive, PIII 400Mhz, 

128Mb ram, 6Gb single internal HD.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install redhat
2.Reboot
3.
	

Actual Results:  Can't load init, leading to a Panic

Expected Results:  Login prompt

Additional info:

Windows 2000 installed, booted and works fine on the machine

Mandrake Installed, then when booting hung when trying to do the partition 
checks, but worked using the flags suggested for redhat from the support guys.

It's stopping me using a purchased copy of Redhat.....
Comment 1 Arjan van de Ven 2002-09-18 09:58:05 EDT
have you tried passing 'ide=nodma' as kernel parameter?
Comment 2 Kevin Walton 2002-09-18 10:51:31 EDT
As above I have tried:

linux text apm=off ide=nodma ide=noautotune

at install boot time, and added to the 'Boot Loader Config' Install screen:

apm=off ide=nodma ide=noautotune

As options to pass to the kernel, without ticking the 'force LBA32' box.  These 
options can then be seen in the FRUB edit box on the kernel line.

hda: irq timeout: status=0xd0 { busy }
partition check:
 hda:hda: status time out ...
hda: drive not ready for command
ide0: rest timeout
...
Mounting Root Filesystem
end_request: I/O error, dev 03:06 (hda), sector 2
EXT3-fs: unable to read superblock
...
Panic

With just ide=nodma the errors are the same as above.

Cheers
Kev
Comment 3 Bugzilla owner 2004-09-30 11:39:55 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.