Bug 742389 - Review Request: gtk-unico-engine - Unico Gtk+ theming engine
Review Request: gtk-unico-engine - Unico Gtk+ theming engine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mario Blättermann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 18:30 EDT by Mohamed El Morabity
Modified: 2014-11-05 13:46 EST (History)
5 users (show)

See Also:
Fixed In Version: gtk-unico-engine-1.0.3-0.6.20140109bzr152.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-05 13:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mario.blaettermann: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Mohamed El Morabity 2011-09-29 18:30:43 EDT
Spec URL: http://melmorabity.fedorapeople.org/packages/gtk-unico-engine/gtk-unico-engine.spec
SRPM URL: http://melmorabity.fedorapeople.org/packages/gtk-unico-engine/gtk-unico-engine-1.0.1-1.fc16.src.rpm
Description:
Unico is a Gtk+ engine that aims to be the more complete yet powerful theming
engine for Gtk+ 3.0 and newer. It’s the first Gtk+ engine written with Gtk+
style context APIs in mind, using CSS as first class citizen.

Notes:
- build fine in mock
- rpmlint:
gtk-unico-engine.src: W: spelling-error Summary(en_US) theming -> teeming, hemming, emitting
gtk-unico-engine.src: W: spelling-error %description -l en_US theming -> teeming, hemming, emitting
gtk-unico-engine.x86_64: W: spelling-error Summary(en_US) theming -> teeming, hemming, emitting
gtk-unico-engine.x86_64: W: spelling-error %description -l en_US theming -> teeming, hemming, emitting
3 packages and 0 specfiles checked; 0 errors, 4 warnings.
Comment 1 Mario Blättermann 2011-09-30 15:08:27 EDT
Nice to have an alternative Gtk3 engine in Fedora, but a naked engine isn't really useful. You should provide at least one theme for it. Either as a second source, which splits into a subpackage, or as a separate package.
Comment 2 Mohamed El Morabity 2011-09-30 15:23:10 EDT
I'm planning to submit also the Light themes from Ubuntu, which requires this GTK engine , as well as the corresponding icons (the packages are already ready, see in http://melmorabity.fedorapeople.org/packages/).
The engine is delivered "as if", and will be packaged "as if".
Comment 3 Mario Blättermann 2011-10-03 14:13:38 EDT
Is it really needed to call gtk-query-immodules in %postun and %post? This command refers to new input methods which have to be found after installation. Does this engine really introduce such input methods? I took a look at gnome-themes-standard, which ships the Adwaita engine for 3.0, and there's not such a script.
Comment 4 Mohamed El Morabity 2011-10-03 14:33:35 EDT
(In reply to comment #3)
> Is it really needed to call gtk-query-immodules in %postun and %post? This
> command refers to new input methods which have to be found after installation.
> Does this engine really introduce such input methods? I took a look at
> gnome-themes-standard, which ships the Adwaita engine for 3.0, and there's not
> such a script.
According to http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#GTK.2B_modules , these scriplets are needed. Without them, it doesn't work.
Comment 5 Mario Blättermann 2011-10-03 15:01:01 EDT
From the mentioned entry in the guidelines:

"The GTK+ toolkit (in the gtk3 package) can be extended by loadable modules which can provide theme engines, input methods, print backends or other functionality. These modules have to be installed in subdirectories of %{_libdir}/gtk-3.0 or %{_libdir}/gtk-3.0/3.0.0. For the input methods, GTK+ maintains a cache in the text file %{_libdir}/gtk-3.0/3.0.0/immodules.cache. This cache file needs to be updated when the set of installed input methods changes, ..."

This refers to modules for input methods, not for GTK modules in general or for theme engines. You might drop the scriptlets.
Comment 6 Mohamed El Morabity 2011-10-03 16:39:37 EDT
And you're absolutely right, sorry for the mistake. I probably made something wrong when I tried the engine without the scriptlets. It works without anyway.
Here is the fixed version:
http://melmorabity.fedorapeople.org/packages/gtk-unico-engine/gtk-unico-engine.spec
http://melmorabity.fedorapeople.org/packages/gtk-unico-engine/gtk-unico-engine-1.0.1-2.fc16.src.rpm
Comment 7 Mario Blättermann 2011-10-04 14:07:14 EDT
Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3402806

$ rpmlint -i -v *gtk-unico-engine.src: I: checking
gtk-unico-engine.src: W: spelling-error Summary(en_US) theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.src: W: spelling-error %description -l en_US theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.src: I: checking-url https://launchpad.net/unico/ (timeout 10 seconds)
gtk-unico-engine.src: I: checking-url http://launchpad.net/unico/1.0/1.0.1/+download/unico-1.0.1.tar.gz (timeout 10 seconds)
gtk-unico-engine.i686: I: checking
gtk-unico-engine.i686: W: spelling-error Summary(en_US) theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.i686: W: spelling-error %description -l en_US theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.i686: I: checking-url https://launchpad.net/unico/ (timeout 10 seconds)
gtk-unico-engine.x86_64: I: checking
gtk-unico-engine.x86_64: W: spelling-error Summary(en_US) theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.x86_64: W: spelling-error %description -l en_US theming -> teeming, hemming, emitting
The value of this tag appears to be misspelled. Please double-check.

gtk-unico-engine.x86_64: I: checking-url https://launchpad.net/unico/ (timeout 10 seconds)
gtk-unico-engine-debuginfo.i686: I: checking
gtk-unico-engine-debuginfo.i686: I: checking-url https://launchpad.net/unico/ (timeout 10 seconds)
gtk-unico-engine-debuginfo.x86_64: I: checking
gtk-unico-engine-debuginfo.x86_64: I: checking-url https://launchpad.net/unico/ (timeout 10 seconds)
gtk-unico-engine.spec: I: checking-url http://launchpad.net/unico/1.0/1.0.1/+download/unico-1.0.1.tar.gz (timeout 10 seconds)
5 packages and 1 specfiles checked; 0 errors, 6 warnings.


Just a few ignoreable spelling errors.



---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license.
    GPL+ or Artistic
[+] MUST: The License field in the package spec file must match the actual
license.
[.] MUST: The file containing the text of the license(s) for the package must
be included in %doc.
[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source.
    $ md5sum *
    1e56ff86337120dcf1b04dd443ea4b71  unico-1.0.1.tar.gz
    1e56ff86337120dcf1b04dd443ea4b71  unico-1.0.1.tar.gz.packaged

[+] MUST: The package MUST successfully compile and build into binary rpms on
at least one primary architecture.
    - Succesful Koji build available.
[.] MUST: If the package does not successfully compile, build or work on an
architecture, ...
[+] MUST: All build dependencies must be listed in BuildRequires.
[.] MUST: The spec file MUST handle locales properly.
[.] MUST: If a package installs files below %{_datadir}/icons, the icon cache
must be updated.
[.] MUST: Packages storing shared library files (not just symlinks) must call
ldconfig in %post and %postun.
[.] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, ...
[+] MUST: A package must own all directories that it creates.
[+] MUST: A Fedora package must not list a file more than once in %files.
[+] MUST: Permissions on files must be set properly.
[+] MUST: Packages must not provide RPM dependency information when that
information is not global in nature, or are otherwise handled.
[.] MUST: When filtering automatically generated RPM dependency information,
the filtering system implemented by Fedora must be used.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage.
[+] MUST: Files in %doc must not affect the runtime of the application.
[.] MUST: Header files must be in a -devel package.
[.] MUST: Static libraries must be in a -static package.
[.] MUST: If a package contains library files with a suffix (e.g.
libfoo.so.1.1), ...
[.] MUST: devel packages must require the base package using a fully versioned
dependency.
[+] MUST: Packages must NOT contain any .la libtool archives.
[.] MUST: Packages containing GUI applications must include a %{name}.desktop
file
[.] MUST: .desktop files must be properly installed with desktop-file-install
in the %install section.
[+] MUST: Packages must not own files or directories already owned by other
packages.
[+] MUST: All filenames in rpm packages must be valid UTF-8.

[.] SHOULD: If the source package does not include license text(s) as a
    separate file from upstream, the packager SHOULD query upstream...
[+] SHOULD: Timestamps of files should be preserved.
[+] SHOULD: The reviewer should test that the package builds in mock.
    See Koji build above (which uses mock anyway)
[+] SHOULD: The reviewer should test that the package functions as described.
    I assume the packager has tested it. Unfortunately, GTK+3 on my
system is too old for that.

[.] SHOULD: If scriptlets are used, those scriptlets must be sane.
[.] SHOULD: Usually, subpackages other than devel should require the base
package using a fully versioned dependency.
[.] SHOULD: pkgconfig(.pc) files should be placed in a -devel pkg.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin,
/usr/bin, or /usr/sbin ...
[.] SHOULD: Your package should contain man pages for binaries/scripts.


----------------

PACKAGE APPROVED

----------------
Comment 8 Mario Blättermann 2011-10-04 14:24:25 EDT
(In reply to comment #7)
> [+] MUST: The package must be licensed with a Fedora approved license.
>     GPL+ or Artistic

Sorry, this comes from copy and paste... Has to be:

[+] MUST: The package must be licensed with a Fedora approved license.
    LGPLv3

Package approved anyway.
Comment 9 Mohamed El Morabity 2011-10-04 19:42:17 EDT
Thanks for your review :)
Comment 10 Mohamed El Morabity 2011-10-04 19:43:33 EDT
New Package SCM Request
=======================
Package Name: gtk-unico-engine
Short Description: Unico Gtk+ theming engine
Owners: melmorabity
Branches: f16
InitialCC:
Comment 11 Jon Ciesla 2011-10-04 20:10:36 EDT
Git done (by process-git-requests).
Comment 12 Fedora Update System 2011-10-05 03:55:05 EDT
gtk-unico-engine-1.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gtk-unico-engine-1.0.1-2.fc16
Comment 13 Fedora Update System 2011-10-05 13:16:35 EDT
gtk-unico-engine-1.0.1-2.fc16 has been pushed to the Fedora 16 testing repository.
Comment 14 Fedora Update System 2011-10-13 00:36:00 EDT
gtk-unico-engine-1.0.1-2.fc16 has been pushed to the Fedora 16 stable repository.
Comment 15 Wolfgang Ulbrich 2014-10-17 09:24:53 EDT
Package Change Request
======================
Package Name: gtk-unico-engine
New Branches: epel7
Owners: raveit65
InitialCC: 

see https://bugzilla.redhat.com/show_bug.cgi?id=1154061

I need the theme engine for my package mate-themes in rhel7/centos7, because
some themes need it as engine.
Comment 16 Jon Ciesla 2014-10-17 13:44:49 EDT
Comments from primary maintainer?
Comment 17 Wolfgang Ulbrich 2014-10-17 17:24:25 EDT
Please take a look at in comment 15 provided link.

I'm not interested in maintaining packages for EPEL. But feel free to request a new epel7 branch for gtk-unico-engine and maintain it ;)

PLease apply
Comment 18 Mohamed El Morabity 2014-10-19 06:05:13 EDT
Package Change Request
======================
Package Name: gtk-unico-engine
New Branches: epel7
Owners: raveit65
InitialCC:
Comment 19 Jon Ciesla 2014-10-20 07:47:39 EDT
Git done (by process-git-requests).
Comment 20 Fedora Update System 2014-10-20 13:49:30 EDT
gtk-unico-engine-1.0.3-0.6.20140109bzr152.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/gtk-unico-engine-1.0.3-0.6.20140109bzr152.el7
Comment 21 Fedora Update System 2014-10-21 12:01:19 EDT
gtk-unico-engine-1.0.3-0.6.20140109bzr152.el7 has been pushed to the Fedora EPEL 7 testing repository.
Comment 22 Fedora Update System 2014-11-05 13:46:25 EST
gtk-unico-engine-1.0.3-0.6.20140109bzr152.el7 has been pushed to the Fedora EPEL 7 stable repository.

Note You need to log in before you can comment on or make changes to this bug.