Bug 742431 - modclusterd memory footprint is growing over time
modclusterd memory footprint is growing over time
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: clustermon (Show other bugs)
6.1
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Pokorný
Cluster QE
:
Depends On: 618321
Blocks: 756082
  Show dependency treegraph
 
Reported: 2011-09-30 01:58 EDT by Fabio Massimo Di Nitto
Modified: 2016-04-26 11:58 EDT (History)
13 users (show)

See Also:
Fixed In Version: modcluster-0.16.2-16.el6
Doc Type: Bug Fix
Doc Text:
Cause * trigger unknown, presumably uncommon event/attribute of the environment Consequence * outgoing queues in inter-nodes communication are growing over time Fix * better balanced inter-nodes communication + restriction of the queues Result * resources utilization kept at reasonable level * possible queues interventions logged in /var/log/clumond.log
Story Points: ---
Clone Of: 618321
Environment:
Last Closed: 2012-06-20 07:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH 1/6] fix bz742431: clarify recv/read_restart+send/write_restart (8.95 KB, patch)
2011-11-24 10:37 EST, Jan Pokorný
no flags Details | Diff
[PATCH 2/6] fix bz742431: introduce per-peer outgoing queue pruning (6.71 KB, patch)
2011-11-24 10:39 EST, Jan Pokorný
no flags Details | Diff
[PATCH 3/6] fix bz742431: limit peer's send() to one message only (1.76 KB, patch)
2011-11-24 10:40 EST, Jan Pokorný
no flags Details | Diff
[PATCH 4/6] fix bz742431: read all available with peer's receive() (1.63 KB, patch)
2011-11-24 10:42 EST, Jan Pokorný
no flags Details | Diff
[PATCH 5/6] fix bz742431: split+restructure poll handling in communicator (8.43 KB, patch)
2011-11-24 10:43 EST, Jan Pokorný
no flags Details | Diff
[PATCH 6/6] fix bz742431: turn off Nagle's alg. in peers' communication (4.10 KB, patch)
2011-11-24 10:44 EST, Jan Pokorný
no flags Details | Diff
bz742431: additional performance improvement patch [1/2] (5.48 KB, patch)
2011-11-24 10:46 EST, Jan Pokorný
no flags Details | Diff
bz742431: additional performance improvement patch [2/2] (3.05 KB, patch)
2011-11-24 10:47 EST, Jan Pokorný
no flags Details | Diff
bz742431: additional fix for a minor memory leak (1.88 KB, patch)
2011-12-06 16:06 EST, Jan Pokorný
no flags Details | Diff

  None (edit)
Comment 1 Fabio Massimo Di Nitto 2011-09-30 02:00:25 EDT
According to:

https://www.redhat.com/archives/linux-cluster/2011-September/msg00067.html

this issue exists in RHEL6 too.
Comment 5 Jan Pokorný 2011-11-24 10:37:19 EST
Created attachment 535954 [details]
[PATCH 1/6] fix bz742431: clarify recv/read_restart+send/write_restart
Comment 6 Jan Pokorný 2011-11-24 10:39:45 EST
Created attachment 535955 [details]
[PATCH 2/6] fix bz742431: introduce per-peer outgoing queue pruning
Comment 7 Jan Pokorný 2011-11-24 10:40:45 EST
Created attachment 535956 [details]
[PATCH 3/6] fix bz742431: limit peer's send() to one message only
Comment 8 Jan Pokorný 2011-11-24 10:42:05 EST
Created attachment 535957 [details]
[PATCH 4/6] fix bz742431: read all available with peer's receive()
Comment 9 Jan Pokorný 2011-11-24 10:43:10 EST
Created attachment 535959 [details]
[PATCH 5/6] fix bz742431: split+restructure poll handling in communicator
Comment 10 Jan Pokorný 2011-11-24 10:44:15 EST
Created attachment 535961 [details]
[PATCH 6/6] fix bz742431: turn off Nagle's alg. in peers' communication
Comment 11 Jan Pokorný 2011-11-24 10:46:20 EST
Created attachment 535963 [details]
bz742431: additional performance improvement patch [1/2]
Comment 12 Jan Pokorný 2011-11-24 10:47:10 EST
Created attachment 535964 [details]
bz742431: additional performance improvement patch [2/2]
Comment 14 Radek Steiger 2011-11-28 13:17:07 EST
As per Comment https://bugzilla.redhat.com/show_bug.cgi?id=618321#c75 acking this for QA using an artificial test as described.
Comment 15 Jan Pokorný 2011-12-06 16:06:05 EST
Created attachment 541598 [details]
bz742431: additional fix for a minor memory leak

Original patch attachment 529083 [details] (accidentally posted
by bug 618321 whereas it should have been here) revisited.

Recap: the leaking triggered with connections to /var/run/clumond.sock
       (2 B per connection IIRC, incomparable with that big memory issue)
Comment 18 Jan Pokorný 2012-04-27 09:58:05 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
* trigger unknown, presumably uncommon event/attribute of the environment
Consequence
* outgoing queues in inter-nodes communication are growing over time
Fix
* better balanced inter-nodes communication + restriction of the queues
Result
* resources utilization kept at reasonable level
* possible queues interventions logged in /var/log/clumond.log
Comment 25 errata-xmlrpc 2012-06-20 07:57:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0750.html

Note You need to log in before you can comment on or make changes to this bug.