Bug 742464 - No Input Methods available on KDE Live spin
No Input Methods available on KDE Live spin
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 04:56 EDT by Akira TAGOH
Modified: 2011-09-30 05:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 05:41:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-09-30 04:56:14 EDT
Description of problem:
no packages available which is supposed to be installed by default in the input methods group in comps.

Version-Release number of selected component (if applicable):
Fedora-16-Beta-x86_64-Live-KDE.iso

How reproducible:
always

Steps to Reproduce:
1.boot up KDE Live
2.rpm -q ibus
3.
  
Actual results:
no ibus nor any "default"/"mandatory" packages in the input methods group in comps

Expected results:
should be available in Live

Additional info:
Comment 1 Kevin Kofler 2011-09-30 05:41:43 EDT
We don't ship full i18n support in the CD-sized KDE spin because there's just no room for it. There are also no translations on it, because there's absolutely no way to ship kde-l10n-* on a CD. We only provide the minimum support so you can read web pages in your language, i.e. fonts. We are aware that that support is not sufficient for actually writing some languages, but a CD just cannot have everything.

The non-default DVD version has full i18n stuff. But for the CD, you have to install it in English and then groupinstall the support for your language, which will also drag in input methods. (You can also run the groupinstall inside the live CD, but that will not be persistent.)

If you really insist, we MIGHT be able to add SOME input methods (I have to check where we are right now size-wise and how much space ibus itself requires), but not if they contain multi-MiB tables (which was why we dropped input methods in the first place).

Note You need to log in before you can comment on or make changes to this bug.