Bug 742482 - pm-suspend not suspending due to spaces in ifcfg (connection name)
pm-suspend not suspending due to spaces in ifcfg (connection name)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 05:54 EDT by Dominick Grift
Modified: 2011-10-03 14:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: dhcp-4.2.2-9.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 742532 (view as bug list)
Environment:
Last Closed: 2011-10-03 14:04:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2011-09-30 05:54:31 EDT
Description of problem:
pm-suspend was exiting with status 1.

after looking in /var/log/pm-suspend.log i found that the ifcfg file was not sourced because it has a space in its name and the script does not support that

/usr/lib64/pm-utils/sleep.d/56dhclient (line 24)

old:
        . ./${ifcfg}

fix:

        . ./"${ifcfg}"

Version-Release number of selected component (if applicable):
pm-utils-1.4.1-12.fc16.x86_64


How reproducible:
use a connection with spaces in its name
Comment 1 Dominick Grift 2011-09-30 06:00:33 EDT
The pm-suspend.log reveals another issue (not fatal)

Running hook /usr/lib64/pm-utils/sleep.d/56atd resume suspend:
/usr/lib64/pm-utils/sleep.d/56atd: line 10: /etc/init.d/atd: No such file or directory

/usr/lib64/pm-utils/sleep.d/56atd resume suspend: Returned exit code 127.
Comment 2 Jaroslav Škarvada 2011-09-30 09:15:53 EDT
Dominick, these hooks are not part of pm-utils, but are shipped in "dhcp" package and "at" package respectively. I will reassign it to "dhcp" and also clone it to "at".
Comment 3 Jiri Popelka 2011-09-30 10:03:05 EDT
Applied. Thanks!
Comment 4 Fedora Update System 2011-09-30 11:23:29 EDT
dhcp-4.2.2-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dhcp-4.2.2-9.fc16
Comment 5 Fedora Update System 2011-09-30 15:14:55 EDT
Package dhcp-4.2.2-9.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.2-9.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dhcp-4.2.2-9.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-10-03 14:04:10 EDT
dhcp-4.2.2-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.