Bug 742612 - F16 Beta rc4 3.5GB DVD still requires net connection to even install
Summary: F16 Beta rc4 3.5GB DVD still requires net connection to even install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: install-guide
Version: devel
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Bokoc
QA Contact: Ruediger Landmann
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-30 18:44 UTC by David Nielsen
Modified: 2013-07-31 14:39 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-07-31 14:39:35 UTC


Attachments (Terms of Use)
anaconda log (12.61 KB, text/plain)
2011-10-04 20:00 UTC, David Nielsen
no flags Details
storage log (211.79 KB, text/plain)
2011-10-04 20:04 UTC, David Nielsen
no flags Details
anaconda.log (13.33 KB, text/x-log)
2011-10-05 15:04 UTC, Daniel Belton
no flags Details
storage.log (244.53 KB, text/x-log)
2011-10-05 15:04 UTC, Daniel Belton
no flags Details

Description David Nielsen 2011-09-30 18:44:46 UTC
Description of problem:

I downloaded the entire 3.5GB RC4 beta DVD because it is currently the only image which is EFI enabled. However on my Mac Mini 5.2 (2011 with Radeon 6630M) the installation failed due to a requirement for a net connection (which I do not have yet in my new apartment). Given that I got 3.5GB of data upfront to install Fedora that surprised me some what that it is insufficient.

Version-Release number of selected component (if applicable):
F16 Beta RC4

How reproducible:
100%

Steps to Reproduce:
1. Start installation process on Mac Mini 5.2
  
Actual results:
failure due to additionally required packages

Expected results:
installation successful

Additional info:

Comment 1 Chris Lumens 2011-09-30 18:55:57 UTC
Please attach /tmp/anaconda.log and /tmp/storage.log to this bug report.  Thanks.

Comment 2 David Nielsen 2011-10-04 20:00:03 UTC
Created attachment 526317 [details]
anaconda log

Comment 3 David Nielsen 2011-10-04 20:04:17 UTC
Created attachment 526318 [details]
storage log

Comment 4 Daniel Belton 2011-10-05 15:01:59 UTC
I am getting the same issue in the F16 beta release.

Created an image of the install DVD onto an USB drive.

Boot the installer, set up the filesystem on the hard drive that I wish to install Fedora to, and then it requires a network connection before continuing.

Also, once you do set up a network connection, it will not recognize the install media as being a repo to do the install from. The only repos listed are 2 fedora online repos. 

It appears that you can not install using the packages on the install dvd if you use a USB drive to install from.

Might the issue be that the installer is looking for a CD/DVD repo, but doesn't recognize the USB drive as a CD/DVD drive?

Comment 5 Daniel Belton 2011-10-05 15:04:10 UTC
Created attachment 526522 [details]
anaconda.log

Comment 6 Daniel Belton 2011-10-05 15:04:52 UTC
Created attachment 526523 [details]
storage.log

Comment 7 Chris Lumens 2011-10-05 15:11:04 UTC
Daniel - your problem seems to be unrelated to the original report.  anaconda will search for a DVD with installation media on it if no other source is given.  Since your command line arguments do not include a repo= and you do not have a DVD, anaconda has no choice but to bring up the network and look for packages there.  It seems like whatever process you used to create the USB image needs to include tweaking the boot arguments to include repo=.  That'd solve this for you.

Comment 8 David Nielsen 2011-10-05 16:46:59 UTC
I created my USB stick using dd if=iso file goes here of=/dev/disk1 bs=1m using the tools included in OS X Lion which makes it bootable using rEFIt. In case that matters.

Comment 9 Daniel Belton 2011-10-05 19:24:45 UTC
I just followed the instructions to create USB install media here:

http://docs.fedoraproject.org/en-US/Fedora/15/html/Installation_Guide/Making_USB_Media-UNIX_Linux.html

Seems like anaconda would search where the installer was started from for a install repo. 

I tried to specify a location for the install repo, but it would not let me choose anything other than a CD/DVD repo, which it could not find a repo on my DVD drive. Or a online repo.

Comment 10 Daniel Belton 2011-10-05 19:31:51 UTC
Actually, it is related to the original report.

I started the install, set up my partition information, then the installer required me to set up a network connection.

The difference is that I set up the network configuration and it went on to choosing the packages and install repos.

What happens if the person that reported this problem sets up a network connection and continues on with the install? Does it find the install repo, or does it give the same error that I got? 

However, this is a moot point for me now since I burned it to a DVD and got past this error, but only to have anaconda completely hose my partition table.

I had a GUID partition table with 4 partitions defined, and anaconda over-wrote my GUID partition table with a MBR partition table leaving me with a corrupted drive.

Comment 11 Chris Lumens 2011-11-02 17:09:37 UTC
The documentation needs to be updated to not suggest this dd procedure.  I am told that livecd-iso-to-disk program will now work fine for non-live media, and that will set up the repo= parameter anaconda is expecting.  We already have more than enough methods of specifying and finding the packages to install.  That code is complex enough as it is.

Comment 12 Karsten Wade 2011-12-14 03:49:00 UTC
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!

Comment 13 Jack Reed 2012-03-01 06:47:06 UTC
Chris,

So to clarify Comment 11, would you recommend removing the dd method entirely from the documentation? Or does it still have some specific applicability that warrants it remaining? 

(I would, of course, strongly recommend in the latter case that users defer to the livecd-tools method, as you suggest.)

Comment 14 Jack Reed 2012-05-03 03:49:37 UTC
Bug 806166 has resolved this issue for F17. A dd'd USB will no longer prompt
for a network connection and does not need a boot prompt.

The procedure has also been updated and verified. See:
http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/Installation_Guide/Making_USB_Media-UNIX_Linux-other-dd.html


Note You need to log in before you can comment on or make changes to this bug.