Bug 742641 - Fedora pypy build not compatible with virtualenv
Fedora pypy build not compatible with virtualenv
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pypy (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 17:19 EDT by Dave Malcolm
Modified: 2012-02-18 16:43 EST (History)
2 users (show)

See Also:
Fixed In Version: pypy-1.8-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-18 16:40:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2011-09-30 17:19:16 EDT
Description of problem:
Our builds of pypy don't seem to be compatible with virtualenv:
  http://mail.python.org/pipermail/pypy-dev/2011-September/008399.html

Version-Release number of selected component (if applicable):
pypy-1.6-4.fc15
as per http://mail.python.org/pipermail/pypy-dev/2011-September/008428.html
Comment 1 Dave Malcolm 2012-01-30 20:01:22 EST
Looks like this relates to my attempts to respect the FHS:
  Patch3: pypy-1.4.1-add-LIBRARY_INSTALLATION_PATH.patch
and:
  https://bugs.pypy.org/issue614
Comment 2 Dave Malcolm 2012-01-31 05:05:23 EST
Fix committed as http://pkgs.fedoraproject.org/gitweb/?p=pypy.git;a=commitdiff;h=a8e52ca5f82917a1b2fb3a3684272c2c1e39f146

Building now (for f17, el6, el5)
Comment 3 Dave Malcolm 2012-01-31 13:56:05 EST
Works with pypy-1.7-4.el6:
[david@rhel6 ~]$ virtualenv -p /usr/bin/pypy my_ve
Running virtualenv with interpreter /usr/bin/pypy
New pypy executable in my_ve/bin/pypy
Installing setuptools............................done.
Installing pip...............done.
[david@rhel6 ~]$ cd my_ve
[david@rhel6 my_ve]$ source bin/activate
(my_ve)[david@rhel6 my_ve]$ 
(my_ve)[david@rhel6 my_ve]$ which python
~/my_ve/bin/python
(my_ve)[david@rhel6 my_ve]$ file $(which python)
/home/david/my_ve/bin/python: symbolic link to `/home/david/my_ve/bin/pypy'
(my_ve)[david@rhel6 my_ve]$ easy_install flask
Searching for flask
Reading http://pypi.python.org/simple/flask/
Reading http://github.com/mitsuhiko/flask/
Best match: Flask 0.8
Downloading http://pypi.python.org/packages/source/F/Flask/Flask-0.8.tar.gz#md5=a5169306cfe49b3b369086f2a63816ab
Processing Flask-0.8.tar.gz
Running Flask-0.8/setup.py -q bdist_egg --dist-dir /tmp/easy_install-XLCKBe/Flask-0.8/egg-dist-tmp-yCLn2e
[...etc...]
Comment 4 Fedora Update System 2012-01-31 13:57:45 EST
pypy-1.7-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0276/pypy-1.7-4.el5
Comment 5 Fedora Update System 2012-01-31 13:58:47 EST
pypy-1.7-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0275/pypy-1.7-4.el6
Comment 6 Fedora Update System 2012-02-18 16:40:25 EST
pypy-1.8-2.el5 has been pushed to the Fedora EPEL 5 stable repository.
Comment 7 Fedora Update System 2012-02-18 16:43:37 EST
pypy-1.8-2.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.