This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 742647 - qemu incorrectly depends on libpulse
qemu incorrectly depends on libpulse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 17:49 EDT by John Schmitt
Modified: 2013-01-09 06:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 04:27:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Schmitt 2011-09-30 17:49:35 EDT
Description of problem:
Removing pulseaudios-libs also removes qemu.

How reproducible:
Always

Steps to Reproduce:
$ yum remove pulseaudio-libs
....

---> Package pulseaudio-libs.x86_64 0:0.9.22-5.fc15 will be erased
...
--> Processing Dependency: libpulse-simple.so.0()(64bit) for package: 2:qemu-system-sh4-0.14.0-7.fc15.x86_64
--> Processing Dependency: libpulse-simple.so.0()(64bit) for package: 2:qemu-system-m68k-0.14.0-7.fc15.x86_64
--> Processing Dependency: libpulse-simple.so.0()(64bit) for package: 2:qemu-system-arm-0.14.0-7.fc15.x86_64
Comment 1 Daniel Berrange 2011-10-03 04:27:48 EDT
The depends on libpulse is *intentional* as PulseAudio is the default host audio driver we build for QEMU. 

* Fri Sep  4 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.91-0.9.rc1
- Make pulseaudio the default audio backend (#519540, #495964, #496627)
Comment 2 John Schmitt 2011-10-07 16:35:52 EDT
I've taken some time to think about this.  

In this context, does default mean "mandatory"?  As far as I can tell by rpm -qil pulseaudio-libs, there isn't even a static pulse library.

Since libpulse is a shared object, you can know whether it's installed by what dlopen() returns.

Note You need to log in before you can comment on or make changes to this bug.