Bug 742714 - LD_DEBUG=scopes broke proprietary nvidia driver
LD_DEBUG=scopes broke proprietary nvidia driver
Status: CLOSED DUPLICATE of bug 737223
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-01 20:44 EDT by nucleo
Modified: 2011-10-03 14:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 14:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nucleo 2011-10-01 20:44:37 EDT
Description of problem:
glxgears and other opengl applications crashes in libGL.so provided by proprietary nvidia driver.

Version-Release number of selected component (if applicable):
glibc-2.14.90-5 and any newer version

How reproducible:
every time

Steps to Reproduce:
1. Install nvidia driver 275.28 (should work with xorg server 1.11.1 in F16)
2. Start X and xterm
3. Try to start glxgears or glxinfo
  
Actual results:
Segmentation fault in libGL.so.275.28.
If glxgears runs in gdb then it not crashes so I am not able to get backtrace.


Additional info:
Downgrading to glibc-2.14.90-4 fixes crash.

Reverting this patch in glibc-2.14.90-5 also fixes crash
http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=73d7af4f4c2b394063cb0b3a33ee2b00b5ad80b4

Here scratch glibc-2.14.90-5 build with reverted patch which works for me http://koji.fedoraproject.org/scratch/nucleo/task_3396071/
Comment 1 Adam Williamson 2011-10-03 14:54:11 EDT

*** This bug has been marked as a duplicate of bug 737223 ***

Note You need to log in before you can comment on or make changes to this bug.