Bug 74273 - FpDelay in trident_drv.o
FpDelay in trident_drv.o
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-19 07:40 EDT by Enrico Segre
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-06 00:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Segre 2002-09-19 07:40:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I've tested 4 different precompiled versions of
/etc/X11R6/lib/modules/drivers/trident_drv.o:

a)the one from XFree86-4.2.0, included in RH 7.3
b)the one from XFree86-4.2.1
c)the one at www.xfree.org/~alanh
d)the one at people.redhat.com/mharris

a) and b) are not accelerated for the Cyberblade XP/Ai1, nor they support Option
"FpDelay" "N" (N=-2:5) in XF86Config-4, but are ok in playing mpeg

c) is accelerated, supports FpDelay, but is buggy vs mpeg reproduction

d) is accelerated and ok about mpeg, but does not support FpDelay

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. drop in /etc/X11R6/lib/modules/drivers/ one of the four .o
2. restart X and login as user to get a WM
3. check GUI acceleration e.g. dragging desktop windows
4. check mpeg reproduction with e.g noatun/kaboodle/mpegartsplay

Actual Results:  With unaccelerated drivers: GUI animations are pretty slow

With mpeg-buggy drivers: the player opens a libmpeg window at position x,y, the
whole screen fills up with copies of line y from y downwards, thus displaying
only a vertical smear of that line, and being unusable. Quitting X, switching to
virtual console do not help: only reboot puts the video card back to an usable mode

Without "FpDelay": on my laptop, the raster falls offscreen by a few pixels to
the right. With alanh's driver, Option "FpDelay" "2" centers it.

Expected Results:  It would be nice that the branches could be merged so that
the driver is accelerated, stable for mpegs and centerable with FpDelay

Additional info:

this refers to my particular laptop, a Toshiba Satellite 1800-712 with a
Cyberblade XP/Ai1

Enhancement request as suggested by Mike Harris, with whom I had private
communication.
Comment 1 Mike A. Harris 2002-10-06 00:46:09 EDT
If there's a newer Trident driver which contains the fixes/features
you're requesting, I'll see about adding them to future erratum.

Adding Alan Hourihane for comment.

TIA
Comment 2 Mike A. Harris 2002-11-07 08:13:10 EST
We do not have Trident hardware available, nor Trident specifications.
As such there is little that I can do to debug or troubleshoot the problem
you are having.

Please report this problem to XFree86.org directly by mailing a bug
report to xfree86@xfree86.org.  You may also want to discuss the problem
on the xpert@xfree86.org mailing list.

If a new release of XFree86 contains an updated driver that does has
the feature you're requesting and solves the problem for you, I can then
investigate the possibility of releasing an updated trident driver in
future erratum.

Since there's no way that we can solve this problem, I'm closing it
as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.