Bug 742744 - [abrt] xfce4-xkb-plugin-0.5.4.1-1.fc16: __stpcpy_sse2_unaligned: Process /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin was killed by signal 11 (SIGSEGV)
Summary: [abrt] xfce4-xkb-plugin-0.5.4.1-1.fc16: __stpcpy_sse2_unaligned: Process /usr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-xkb-plugin
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fe2912205ab1a4ed58bb2c3d792...
: 751633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-02 11:10 UTC by Alexei Panov
Modified: 2012-12-20 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 16:05:52 UTC


Attachments (Terms of Use)
File: event_log (7.32 KB, text/plain)
2011-10-02 11:10 UTC, Alexei Panov
no flags Details
File: coredump (11.69 MB, text/plain)
2011-10-02 11:13 UTC, Alexei Panov
no flags Details
File: maps (24.71 KB, text/plain)
2011-10-02 11:13 UTC, Alexei Panov
no flags Details
File: smolt_data (4.81 KB, text/plain)
2011-10-02 11:13 UTC, Alexei Panov
no flags Details
File: backtrace (35.49 KB, text/plain)
2011-10-02 11:13 UTC, Alexei Panov
no flags Details

Description Alexei Panov 2011-10-02 11:10:02 UTC
libreport version: 2.0.5.982
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin '' 16 16777265 xkb-plugin '\xd0\xa0\xd0\xb0\xd1\x81\xd0\xba\xd0\xbb\xd0\xb0\xd0\xb4\xd0\xba\xd0\xb8 \xd0\xba\xd0\xbb\xd0\xb0\xd0\xb2\xd0\xb8\xd0\xb0\xd1\x82\xd1\x83\xd1\x80\xd1\x8b' '\xd0\x9d\xd0\xb0\xd1\x81\xd1\x82\xd1\x80\xd0\xbe\xd0\xb9\xd0\xba\xd0\xb0 \xd0\xb8 \xd0\xbf\xd0\xb5\xd1\x80\xd0\xb5\xd0\xba\xd0\xbb\xd1\x8e\xd1\x87\xd0\xb5\xd0\xbd\xd0\xb8\xd0\xb5 \xd0\xba\xd0\xbb\xd0\xb0\xd0\xb2\xd0\xb8\xd0\xb0\xd1\x82\xd1\x83\xd1\x80\xd0\xbd\xd1\x8b\xd1\x85 \xd1\x80\xd0\xb0\xd1\x81\xd0\xba\xd0\xbb\xd0\xb0\xd0\xb4\xd0\xbe\xd0\xba' ''
crash_function: __stpcpy_sse2_unaligned
executable:     /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin
kernel:         3.1.0-0.rc8.git0.0.fc16.x86_64
reason:         Process /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin was killed by signal 11 (SIGSEGV)
time:           Sun Oct  2 15:05:22 2011
uid:            500
username:       alex
xsession_errors: 

backtrace:      Text file, 36338 bytes
event_log:      Binary file, 7492 bytes
maps:           Text file, 25304 bytes
smolt_data:     Binary file, 4930 bytes

build_ids:
:37d977659123fa04606aa35cba63f9491cc75bbf
:989ae6528c12f0c2860156deb76c7eed3dbdf9c4
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:98fa95d21e16075ada6df19748c6c133ee9165d0
:49b317bbb2da7be48ba3b947e23703ba6397dbf4
:ddf1c57f9c14dece523e2ab2f32b0e963543e7f8
:f9a1b6daef0430cb9fd451e3887cf2d97c5e2845
:1c6a95451ee19617be5abea3d121f0226d21ddda
:f47fce6e45fa4fdaf051267eaa7ed685f4f9125e
:d72205b8aaeac3286c0a4f9f38449b0557002a71
:7648e8db912690e64451b64dcf0afdc4516ef73f
:d0c6e13f00a20952a72a945c929efb175fd760e3
:8ca893c2cf400317322477c03e6b754bd2533a3a
:aaf62304b0fc10611d35b4f56005479d4c58868d
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:eacb8020c70b5844d07665eeb30f91e924a92bb2
:f0d50e3af2dfee021a327fb85a993a2312a98145
:366db4bf15a0c9da945955717b40cc226a8ad562
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:556c0b7d4968c111101b7fec18336bbcbd16079d
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:f7171eec924b093eeb204bcf7fc93c392c9399a1
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:25b834f4c4dc534708635ff1064e2fe02a366a62
:dfc1b11c1ced5c134adca2b29874a41f39f0eeaf
:163b323da65b708418226eb5fa8b057c731d1475
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:0911ea7c180d733724f89037b8e8a34e64024aec
:2431b55e3253fab5169f214c6cb29cf8d92e8d0d
:91709dc7083204ddd936d5ad28c171985f06f66c
:ddda5b85a9d1d9a2111035e8d350615513dcbe27
:64637e5888dd44961c65240e8568f2af777b543a
:cb04056dcb40f1e6ef5df3e1299aeffcbc727e4a
:ed91e7cbb6d7056226b7d9d50fff88e24dd5eaac
:86282c15cdb7f190b236c8f0d3dbd97b1bc6f3e6
:4c842320387ff7f6f91b7842b223c16518be909f
:9e81d9a5f63b4ff66b5e3e2fc96b46a6d67a8153
:9523adec86a142d4e4521da1cabb80c64c5fbad7
:5b5c1086424f261b1d3264999be0fb3189156969
:15c6b928aab48e116eca35337aa3c72b61179000
:4b01fe6e705219deca2756ff0720d52ec81b4c87
:07470201df55a5254027d05fa4dc509b10f2986a
:33001d9c43203911ccf35a2f3db5b6b2d70cb292
:91689252818532ec13597b6528d38be93b2706c4
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:c0516bb2083183aa526e64fdc452a92d9a0e4f4f
:33d2ab2ee0f9451d3d39cb670b1b5821ab848cc4
:b038838c10d38141b6ec19b40168be9caaa78286
:ccb73bf0ed7094af175b72c6e605472777dc05aa
:23b6792e3218744316fd495002f40a037c2e0095
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:790f206de27690431bcd8fd1c818faf3375a83c6
:f1ed2e993eada8d974044e16902b843651e918b4
:d440afe7396b3365dcb935f9bf7f2fb28f3839de
:48aea888319e1848137073c9cbde54a4c2a731c9
:ee8a8ced576ef1c94d19f9749154d86dc77ffebb
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:a518a8b1b5c3e80dee813df05e951d205d6ac48c
:8ec458a1d4aa9f77a71fc6cb5f7a958c0b27f927
:1406558950ff100eb0320a325b3ea7961ba1a775

comment:
:Doing nothing. 
:abrt show xfce4-xkb-plugin sigsegv bug. 
:xkb-plugin from the panel was not lost.

dso_list:
:/usr/lib64/libXcursor.so.1.0.2 libXcursor-1.1.11-3.fc15.x86_64 (Fedora Project) 1312824172
:/lib64/libm-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-3.fc16.x86_64 (Fedora Project) 1317032703
:/usr/lib64/libpixman-1.so.0.22.2 pixman-0.22.2-1.fc16.x86_64 (Fedora Project) 1317032714
:/usr/lib64/libpango-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1317414402
:/usr/share/locale/ru/LC_MESSAGES/gtk20.mo gtk2-2.24.6-1.fc16.x86_64 (Fedora Project) 1317032910
:/usr/share/locale/ru/LC_MESSAGES/gtk20-properties.mo gtk2-devel-2.24.6-1.fc16.x86_64 (Fedora Project) 1317034061
:/usr/share/locale/ru/LC_MESSAGES/libc.mo glibc-common-2.14.90-10.x86_64 (Fedora Project) 1317328756
:/usr/lib64/libX11-xcb.so.1.0.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1317032704
:/lib64/libgmodule-2.0.so.0.3000.0 glib2-2.30.0-1.fc16.x86_64 (Fedora Project) 1317414397
:/lib64/libresolv-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1317035725
:/usr/lib64/gconv/ISO8859-1.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libxkbfile.so.1.0.2 libxkbfile-1.0.7-2.fc15.x86_64 (Fedora Project) 1312824191
:/usr/lib64/libSM.so.6.0.1 libSM-1.2.0-2.fc15.x86_64 (Fedora Project) 1312824166
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libfontconfig.so.1.4.4 fontconfig-2.8.0-4.fc16.1.R.x86_64 (Russian Fedora Team) 1317035717
:/lib64/libpthread-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/lib64/libexpat.so.1.5.2 expat-2.0.1-11.fc15.x86_64 (Fedora Project) 1312824166
:/usr/lib64/libXfixes.so.3.1.0 libXfixes-5.0-1.fc16.x86_64 (Fedora Project) 1317032704
:/lib64/libglib-2.0.so.0.3000.0 glib2-2.30.0-1.fc16.x86_64 (Fedora Project) 1317414397
:/usr/lib64/libpangoft2-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1317414402
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1312824171
:/lib64/libgobject-2.0.so.0.3000.0 glib2-2.30.0-1.fc16.x86_64 (Fedora Project) 1317414397
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1317032704
:/usr/lib64/libXinerama.so.1.0.0 libXinerama-1.1.1-2.fc15.x86_64 (Fedora Project) 1312824173
:/usr/lib64/libXdamage.so.1.1.0 libXdamage-1.1.3-2.fc15.x86_64 (Fedora Project) 1312824172
:/usr/lib64/libxml2.so.2.7.8 libxml2-2.7.8-6.fc16.x86_64 (Fedora Project) 1317032692
:/usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so gtk2-engines-2.20.2-2.fc15.x86_64 (Fedora Project) 1312824275
:/usr/share/locale/ru/LC_MESSAGES/gdk-pixbuf.mo gdk-pixbuf2-2.24.0-1.fc16.x86_64 (Fedora Project) 1317032735
:/lib64/libdl-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libXRes.so.1.0.0 libXres-1.0.5-2.fc15.x86_64 (Fedora Project) 1312824199
:/lib64/libuuid.so.1.3.0 libuuid-2.20-1.fc16.x86_64 (Fedora Project) 1317032701
:/usr/lib64/libxfce4util.so.4.1.1 libxfce4util-4.8.2-1.fc16.x86_64 (Fedora Project) 1317035734
:/usr/lib64/libpng12.so.0.46.0 libpng-2:1.2.46-1.fc16.x86_64 (Fedora Project) 1317032690
:/usr/lib64/libatk-1.0.so.0.20209.1 atk-2.2.0-1.fc16.x86_64 (Fedora Project) 1317414404
:/lib64/libc-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/lib64/libgcc_s-4.6.1-20110908.so.1 libgcc-4.6.1-9.fc16.x86_64 (Fedora Project) 1317035695
:/lib64/librt-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libICE.so.6.3.0 libICE-1.0.7-1.fc16.x86_64 (Fedora Project) 1317032692
:/usr/lib64/libcroco-0.6.so.3.0.1 libcroco-0.6.2-6.fc15.x86_64 (Fedora Project) 1312824200
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1312824171
:/usr/share/locale/ru/LC_MESSAGES/libwnck.mo libwnck-2.30.7-1.fc16.x86_64 (Fedora Project) 1317032917
:/usr/lib64/libpangocairo-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1317414402
:/usr/lib64/libXrandr.so.2.2.0 libXrandr-1.3.1-2.fc15.x86_64 (Fedora Project) 1312824171
:/lib64/libz.so.1.2.5 zlib-1.2.5-4.fc16.x86_64 (Fedora Project) 1317032689
:/lib64/ld-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1317328749
:/usr/lib64/libXext.so.6.4.0 libXext-1.2.0-2.fc15.x86_64 (Fedora Project) 1312824171
:/lib64/libgthread-2.0.so.0.3000.0 glib2-2.30.0-1.fc16.x86_64 (Fedora Project) 1317414397
:/usr/lib/locale/locale-archive glibc-common-2.14.90-10.x86_64 (Fedora Project) 1317328756
:/usr/lib64/libXcomposite.so.1.0.0 libXcomposite-0.4.3-2.fc15.x86_64 (Fedora Project) 1312824172
:/usr/lib64/libxcb-aux.so.0.0.0 xcb-util-0.3.6-2.fc15.x86_64 (Fedora Project) 1312824172
:/usr/lib64/libxklavier.so.16.1.0 libxklavier-5.1-1.fc15.x86_64 (Fedora Project) 1312824191
:/usr/lib64/libcairo.so.2.11000.2 cairo-1.10.2-4.fc16.x86_64 (Fedora Project) 1317032865
:/usr/lib64/libfreetype.so.6.7.1 freetype-2.4.6-1.fc16.1.R.x86_64 (Russian Fedora Team) 1317042661
:/usr/lib64/libstartup-notification-1.so.0.0.0 startup-notification-0.12-1.fc16.x86_64 (Fedora Project) 1317032714
:/usr/lib64/libXi.so.6.1.0 libXi-1.4.3-2.fc16.x86_64 (Fedora Project) 1317032710

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SSH_AGENT_PID=2175
:HOSTNAME=alex-desktop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/gpg-zrvf1l/S.gpg-agent:2194:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=c2835320a2995c0fbb0bd7ba0000000d-1317542123.249095-971897256
:GNOME_KEYRING_CONTROL=/tmp/keyring-1NbwHh
:'IMSETTINGS_MODULE=X compose table'
:USER=alex
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-xfJgBcKX2053/agent.2053
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/alex
:PATH=/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/alex/bin
:DESKTOP_SESSION=/usr/bin/startxfce4
:QT_IM_MODULE=xim
:PWD=/home/alex
:XMODIFIERS=@im=none
:EDITOR=/usr/local/bin/console_emacs
:LANG=ru_RU.UTF-8
:GNOME_KEYRING_PID=1986
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:KEYTABLE=ru
:SHLVL=2
:HOME=/home/alex
:XDG_SEAT=seat0
:BOOT_IMAGE=/vmlinuz-3.1.0-0.rc8.git0.0.fc16.x86_64
:LOGNAME=alex
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-AQCGaED71w,guid=63c6e12e7d83c1c66832d8d600000029
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:PREFERRED=/usr/bin/startxfce4
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/alex
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:GTK_IM_MODULE=xim
:XAUTHORITY=/home/alex/.Xauthority
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2203,unix/unix:/tmp/.ICE-unix/2203

var_log_messages:
:Oct  2 15:05:22 localhost abrt[30267]: file /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin.#prelink#.lUzr3X seems to be deleted
:Oct  2 15:05:22 localhost abrt[30267]: file /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin.#prelink#.lUzr3X seems to be a prelink temporary file
:Oct  2 15:05:23 localhost abrt[30267]: saved core dump of pid 2569 (/usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin) to /var/spool/abrt/ccpp-2011-10-02-15:05:22-2569 (12259328 bytes)

Comment 1 Alexei Panov 2011-10-02 11:10:05 UTC
Created attachment 525918 [details]
File: event_log

Comment 2 Alexei Panov 2011-10-02 11:13:08 UTC
Created attachment 525920 [details]
File: coredump

Comment 3 Alexei Panov 2011-10-02 11:13:11 UTC
Created attachment 525921 [details]
File: maps

Comment 4 Alexei Panov 2011-10-02 11:13:13 UTC
Created attachment 525922 [details]
File: smolt_data

Comment 5 Alexei Panov 2011-10-02 11:13:15 UTC
Created attachment 525923 [details]
File: backtrace

Comment 6 Christoph Wickert 2011-11-06 17:11:27 UTC
*** Bug 751633 has been marked as a duplicate of this bug. ***

Comment 7 igor.redhat@gmail.com 2011-11-07 17:10:58 UTC
Package: xfce4-xkb-plugin-0.5.4.1-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Happened on it own

Comment 8 Christoph Wickert 2011-11-07 17:50:01 UTC
What exactly do you mean by "Happened on it own"? Does it mean that is was random any you cannot reproduce it or that you were not even at your computer when it happened?

Comment 9 igor.redhat@gmail.com 2011-11-07 18:57:00 UTC
(In reply to comment #8)
> What exactly do you mean by "Happened on it own"?

The former - I was at my computer when this happened but I wasn't doing anything related to the functionality of xfce4-xkb-plugin; it was along the lines of me staring at a browser window and then the abortd report suddenly popping up.

Comment 10 Fedora Update System 2012-10-15 16:31:54 UTC
xfce4-xkb-plugin-0.5.4.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.4.3-2.fc18

Comment 11 Fedora Update System 2012-10-15 16:32:53 UTC
xfce4-xkb-plugin-0.5.4.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.4.3-2.fc17

Comment 12 Fedora Update System 2012-10-15 16:33:37 UTC
xfce4-xkb-plugin-0.5.4.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.4.3-2.fc16

Comment 13 Fedora Update System 2012-10-15 23:26:10 UTC
Package xfce4-xkb-plugin-0.5.4.3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-xkb-plugin-0.5.4.3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16146/xfce4-xkb-plugin-0.5.4.3-2.fc16
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2012-12-20 16:05:55 UTC
xfce4-xkb-plugin-0.5.4.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.