Bug 742817 - Battery life is cut in half on 2.6.40-4.fc15.x86_64 or higher
Battery life is cut in half on 2.6.40-4.fc15.x86_64 or higher
Status: CLOSED DUPLICATE of bug 727579
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-02 22:00 EDT by Jeremy
Modified: 2011-10-06 09:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-06 09:42:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2011-10-02 22:00:06 EDT
Description of problem:After updating from kernel-2.6.38.8-35.fc15.x86_64 to kernel-2.6.40-4.fc15.x86_64, my battery life on a Lenovo X220 thinkpad went from 8 hours on a full charge to 4 hours. I can validate the longer battery life by booting on 2.6.38.8-35.f15.


Version-Release number of selected component (if applicable): 2.6.40-4.fc15


How reproducible: 100%


Steps to Reproduce:
1.Boot system with a fully charged battery on kernel-2.6.38.8-35.fc15
2.Use system for ~8 hours on battery.
3.Boot system with a fully charged batter on kernel-2.6.20-4.fc15
4.Use system for only ~4 hours on battery.
  
Actual results:Battery life time is half of what it was on the older kernel.


Expected results: Same battery life time on newer kernels.


Additional info:I'm not sure what kind debug/log info would be needed to investigate. Let me know and I'll grab it.
Comment 1 Dave Jones 2011-10-03 11:45:32 EDT
Try adding i915.i915_enable_rc6=1 to your grub command line
Comment 2 Jeremy 2011-10-05 17:24:25 EDT
This has not helped my battery life. Occasionally I see the power indicator (in gnome-shell) show better time expected, but that usually only happens right after time of idle. Once I start using the system (terminal/ssh sessions -- SA work) it goes back down.
Comment 3 Jeremy 2011-10-06 09:42:11 EDT
found I had to add pcie_aspm=force to get back to batter usage I was used to. Found it in 727579

*** This bug has been marked as a duplicate of bug 727579 ***

Note You need to log in before you can comment on or make changes to this bug.