Bug 743082 - subscribe --auto output appears to report a stale status of the installed products
subscribe --auto output appears to report a stale status of the installed pro...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
: Regression
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-10-03 15:35 EDT by John Sefler
Modified: 2013-01-10 05:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:25:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-10-03 15:35:02 EDT
Description of problem:
subscription-manager subscribe --auto appears to report the stale "status" results


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
'subscription-manager-0.96.11-1.git.24.2234bc3.el6.x86_64

How reproducible:


Steps to Reproduce:



[root@jsefler-onprem-62server ~]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with id: 50bcda3b-ba11-4544-8a88-a033ed68c964 
[root@jsefler-onprem-62server ~]# subscription-manager subscribe --auto
Installed Product Current Status:

ProductName:         	Awesome OS for ia64 Bits 
Status:               	Not Subscribed           


ProductName:         	Stackable with Awesome OS for x86_64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS Developer Basic
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for z80/x86_64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for z80/ALL Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64/ALL Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64/ALL Bits for ZERO sockets
Status:               	Not Subscribed           


ProductName:         	Awesome OS Workstation Bits
Status:               	Not Subscribed           


ProductName:         	Red Hat Enterprise Linux Server
Status:               	Not Subscribed           


ProductName:         	Awesome OS Scalable Filesystem Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS Developer Bits
Status:               	Not Subscribed           


ProductName:         	Management Bits          
Status:               	Not Subscribed           


ProductName:         	Large File Support Bits  
Status:               	Not Subscribed           


ProductName:         	Awesome OS Modifier Bits 
Status:               	Not Subscribed           


ProductName:         	Clustering Bits          
Status:               	Not Subscribed           


ProductName:         	Shared Storage Bits      
Status:               	Not Subscribed           


ProductName:         	Awesome OS Server Bits   
Status:               	Not Subscribed           


ProductName:         	Awesome OS Premium Architecture Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for S390 Bits 
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i686/x86_64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for z80 Bits  
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i686 Bits 
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for ppc64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for S390X Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i386 Bits 
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86 Bits  
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64/s390x Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for Intel x86_64/i686/ia64 Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86/x64_64 Bits
Status:               	Not Subscribed           


ProductName:         	Multiplier Product Bits  
Status:               	Not Subscribed           


ProductName:         	Load Balancing Bits      
Status:               	Not Subscribed           



                        ^^^^^^^^^^^^^^ NOTICE THAT THE STATUS OF ALL THE INSTALLED PRODUCTS IS "Not Subscribed", YET THE FOLLOWING ENTITLEMENT CERTS HINT THAT THEY REALLY WERE SUBSCRIBED...



[root@jsefler-onprem-62server ~]# ls -l /etc/pki/entitlement/*.pem | grep -v key
-rw-r--r--. 1 root root 3662 Oct  3 15:08 /etc/pki/entitlement/142341000682022408.pem
-rw-r--r--. 1 root root 3613 Oct  3 15:08 /etc/pki/entitlement/1867285141955312689.pem
-rw-r--r--. 1 root root 3930 Oct  3 15:08 /etc/pki/entitlement/2523933954606357046.pem
-rw-r--r--. 1 root root 3304 Oct  3 15:08 /etc/pki/entitlement/2629627463401012568.pem
-rw-r--r--. 1 root root 3642 Oct  3 15:08 /etc/pki/entitlement/2654042151086471785.pem
-rw-r--r--. 1 root root 3829 Oct  3 15:08 /etc/pki/entitlement/5559397286373117162.pem
-rw-r--r--. 1 root root 2715 Oct  3 15:08 /etc/pki/entitlement/6287846065249541033.pem
-rw-r--r--. 1 root root 2224 Oct  3 15:08 /etc/pki/entitlement/6573441978710966410.pem
-rw-r--r--. 1 root root 3654 Oct  3 15:08 /etc/pki/entitlement/6945162363480504043.pem
-rw-r--r--. 1 root root 3646 Oct  3 15:08 /etc/pki/entitlement/7008562089031462342.pem
-rw-r--r--. 1 root root 4771 Oct  3 15:08 /etc/pki/entitlement/7027942642747168034.pem
-rw-r--r--. 1 root root 2971 Oct  3 15:08 /etc/pki/entitlement/7072608510501831008.pem
-rw-r--r--. 1 root root 3369 Oct  3 15:08 /etc/pki/entitlement/7192000476004575411.pem
-rw-r--r--. 1 root root 5149 Oct  3 15:08 /etc/pki/entitlement/7446200369147164204.pem
-rw-r--r--. 1 root root 2996 Oct  3 15:08 /etc/pki/entitlement/7650389053691822726.pem
[root@jsefler-onprem-62server ~]# ls -l /etc/pki/entitlement/*.pem | grep -v key | wc -l
15


NOW LET"S TRY AUTOSUBSCRIBE AGAIN...


[root@jsefler-onprem-62server ~]# subscription-manager subscribe --auto
Installed Product Current Status:

ProductName:         	Awesome OS for ia64 Bits 
Status:               	Subscribed               


ProductName:         	Stackable with Awesome OS for x86_64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS Developer Basic
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for z80/x86_64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for z80/ALL Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for x86_64/ALL Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for x86_64/ALL Bits for ZERO sockets
Status:               	Subscribed               


ProductName:         	Awesome OS Workstation Bits
Status:               	Subscribed               


ProductName:         	Red Hat Enterprise Linux Server
Status:               	Not Subscribed           


ProductName:         	Awesome OS Scalable Filesystem Bits
Status:               	Subscribed               


ProductName:         	Awesome OS Developer Bits
Status:               	Not Subscribed           


ProductName:         	Management Bits          
Status:               	Subscribed               


ProductName:         	Large File Support Bits  
Status:               	Subscribed               


ProductName:         	Awesome OS Modifier Bits 
Status:               	Subscribed               


ProductName:         	Clustering Bits          
Status:               	Subscribed               


ProductName:         	Shared Storage Bits      
Status:               	Subscribed               


ProductName:         	Awesome OS Server Bits   
Status:               	Subscribed               


ProductName:         	Awesome OS Premium Architecture Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for S390 Bits 
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i686/x86_64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for z80 Bits  
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i686 Bits 
Status:               	Not Subscribed           


ProductName:         	Awesome OS for x86_64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for ppc64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for S390X Bits
Status:               	Not Subscribed           


ProductName:         	Awesome OS for i386 Bits 
Status:               	Subscribed               


ProductName:         	Awesome OS for x86 Bits  
Status:               	Subscribed               


ProductName:         	Awesome OS for x86_64/s390x Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for Intel x86_64/i686/ia64 Bits
Status:               	Subscribed               


ProductName:         	Awesome OS for x86/x64_64 Bits
Status:               	Subscribed               


ProductName:         	Multiplier Product Bits  
Status:               	Not Subscribed           


ProductName:         	Load Balancing Bits      
Status:               	Subscribed               



                        ^^^^^^^^^^ NOW THE STATUS SHOWS SOME SUBSCRIBES


[root@jsefler-onprem-62server ~]# ls -l /etc/pki/entitlement/*.pem | grep -v key
-rw-r--r--. 1 root root 3662 Oct  3 15:08 /etc/pki/entitlement/142341000682022408.pem
-rw-r--r--. 1 root root 3613 Oct  3 15:08 /etc/pki/entitlement/1867285141955312689.pem
-rw-r--r--. 1 root root 3930 Oct  3 15:08 /etc/pki/entitlement/2523933954606357046.pem
-rw-r--r--. 1 root root 3304 Oct  3 15:08 /etc/pki/entitlement/2629627463401012568.pem
-rw-r--r--. 1 root root 3642 Oct  3 15:08 /etc/pki/entitlement/2654042151086471785.pem
-rw-r--r--. 1 root root 3829 Oct  3 15:08 /etc/pki/entitlement/5559397286373117162.pem
-rw-r--r--. 1 root root 2715 Oct  3 15:08 /etc/pki/entitlement/6287846065249541033.pem
-rw-r--r--. 1 root root 2224 Oct  3 15:08 /etc/pki/entitlement/6573441978710966410.pem
-rw-r--r--. 1 root root 3654 Oct  3 15:08 /etc/pki/entitlement/6945162363480504043.pem
-rw-r--r--. 1 root root 3646 Oct  3 15:08 /etc/pki/entitlement/7008562089031462342.pem
-rw-r--r--. 1 root root 4771 Oct  3 15:08 /etc/pki/entitlement/7027942642747168034.pem
-rw-r--r--. 1 root root 2971 Oct  3 15:08 /etc/pki/entitlement/7072608510501831008.pem
-rw-r--r--. 1 root root 3369 Oct  3 15:08 /etc/pki/entitlement/7192000476004575411.pem
-rw-r--r--. 1 root root 5149 Oct  3 15:08 /etc/pki/entitlement/7446200369147164204.pem
-rw-r--r--. 1 root root 2996 Oct  3 15:08 /etc/pki/entitlement/7650389053691822726.pem
[root@jsefler-onprem-62server ~]# ls -l /etc/pki/entitlement/*.pem | grep -v key | wc -l
15
[root@jsefler-onprem-62server ~]#
Comment 2 J.C. Molet 2011-10-05 11:42:26 EDT
verified against 

[root@mgmt5 candlepin]# git show
commit 5340dfd5b25440d227ee22940da712516a4989bb


python-rhsm-0.96.13-1.git.0.a237980.el6.noarch
subscription-manager-firstboot-0.96.13-1.git.0.b1b0502.el6.x86_64
subscription-manager-0.96.13-1.git.0.b1b0502.el6.x86_64
subscription-manager-gnome-0.96.13-1.git.0.b1b0502.el6.x86_64


[root@jmolet-vm0 ~]# subscription-manager unregister
System has been un-registered.
[root@jmolet-vm0 ~]# subscription-manager register --user testuser1 --pass
password --org admin
The system has been registered with id: 45e3fa4c-c849-4448-bd8a-30755ce017d5 
[root@jmolet-vm0 ~]# subscription-manager subscribe --auto
Installed Product Current Status:

ProductName:          Stackable with Awesome OS for x86_64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Status:                Subscribed               


ProductName:          Awesome OS for z80/x86_64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for z80/ALL Bits
Status:                Subscribed               


ProductName:          Awesome OS for x86_64/ALL Bits
Status:                Subscribed               


ProductName:          Awesome OS for x86_64/ALL Bits for ZERO sockets
Status:                Subscribed               


ProductName:          Management Bits          
Status:                Subscribed               


ProductName:          Large File Support Bits  
Status:                Subscribed               


ProductName:          Awesome OS Modifier Bits 
Status:                Subscribed               


ProductName:          Clustering Bits          
Status:                Subscribed               


ProductName:          Shared Storage Bits      
Status:                Subscribed               


ProductName:          Awesome OS Server Bits   
Status:                Subscribed               


ProductName:          Awesome OS for ia64 Bits 
Status:                Subscribed               


ProductName:          Awesome OS for i686/x86_64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for x86_64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for ppc64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for i386 Bits 
Status:                Subscribed               


ProductName:          Awesome OS for x86 Bits  
Status:                Subscribed               


ProductName:          Awesome OS for x86_64/s390x Bits
Status:                Subscribed               


ProductName:          Awesome OS for Intel x86_64/i686/ia64 Bits
Status:                Subscribed               


ProductName:          Awesome OS for x86/x64_64 Bits
Status:                Subscribed               


ProductName:          Awesome OS Scalable Filesystem Bits
Status:                Subscribed               


ProductName:          Load Balancing Bits      
Status:                Subscribed               


all status tags updated upon the first autosubscribe. Marking VERIFIED.
Comment 3 errata-xmlrpc 2011-12-06 12:25:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.