Bug 743098 - RFE: API results for channel.software.clone does not match channel.software.getDetails
RFE: API results for channel.software.clone does not match channel.software.g...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
1.5
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: spacewalk-rfe
  Show dependency treegraph
 
Reported: 2011-10-03 16:15 EDT by lance dillon
Modified: 2011-12-23 05:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 05:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lance dillon 2011-10-03 16:15:02 EDT
Description of problem:
API results for channel.software.clone does not match channel.software.getDetails.  getDetails returns gpg_key_{fp,id,url}, but clone takes gpg_{url,id,fingerprint} instead.  This requires programming to convert one to the other (if you are copying that info also) instead of just being able to assign/copy the details.

Version-Release number of selected component (if applicable):
1.5

How reproducible:
Call channel.software.getDetails, notice that result has gpg_key_{fp,id,url}, but http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/API_Overview/handlers/ChannelSoftwareHandler.html#clone says:
string "gpg_url" - (optional) 
string "gpg_id" - (optional) 
string "gpg_fingerprint" - (optional)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Not sure I have expected results other than would like the names to be the same so that programmatically it is easier to deal with those values.


Additional info:
It may not be possible to change if too many things are using the api as it is.  This is really a low priority item, more of a "Would be nice..." than a bug.
Comment 1 Tomas Lestach 2011-12-16 05:42:43 EST
Yes, I like this RFE.
I changed the channel.software.clone API parameters to use: gpg_key_url, gpg_key_id and gpg_key_fp.
However, the original parameters are still usable because of compatibility reasons.

spacewalk.git: f95263e9b019d791941942e2ec262c4709f14f74
Comment 2 Milan Zazrivec 2011-12-23 05:02:37 EST
Spacewalk 1.6 has been released.

Note You need to log in before you can comment on or make changes to this bug.