Bug 7431 - dhcp eth0 interface hangs
dhcp eth0 interface hangs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
http://www.waypointZero.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-29 21:53 EST by Craig Guthrie
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-13 09:19:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Guthrie 1999-11-29 21:53:36 EST
We are using dhcp with success. The problem is that when I do a shutdown -r
or a shutdown -h the processes all halt except when the eth0 interface
attempts to unload. This hangs the system and it is unable to complete the
shutdown process.

The dhcp server is a Windows NT Server 4.0 and the network traffic between
it and the RH Linux 6.1 computer is active (as indicated with flashing
lights on the ethernet hub).

Other than this the network works great, dhcp works great, and everything
is fine. Of course since I cannot ever complete the shutdown process I am
forced to run an fsck each time I boot linux, which is not good. Your help
is greatly appreciated.
Craig Guthrie
Software Engineering
waypoint Zero, Inc.
888-682-5936
Comment 1 Evers Ding 1999-12-10 17:32:59 EST
I have the same problem.  I'm using a freshly installed RedHat 6.1 on a
Thinkpad 600E.  The network adapter is a Xircom Cardbus 10/100 Multifn card
(using the tulip PCMCIA driver).  Everything works dandy, network included,
until I try to shutdown.  It hangs on the "Shutting down interface eth0"
message; "/sbin/ifdown eth0" also appears to hang.
Comment 2 Ian Cameron 2000-01-16 09:20:59 EST
Me too :-)  I'm running a P120 with a stock RH6.1 install using a DE100 and the
DEPCA module.  My DHCP server is an RH5.2 box.  The RH6.1 box stops at shutting
down the eth0 interface and can only be rebooted at this stage.  The interface
of the RH6.1 box goes down (machine cannot be pinged) and the DHCP server log on
the RH5.2 box shows that the assigned IP address has been released.  If I issue
the command '/etc/rc.d/init.d/network stop' as root by hand the machine will
lock up as well.  A Windows 95 box using a DHCP client on the same network
(getting the same address when the RH6.1 box is not up as I'm sharing the
ethernet card at the moment) works fine.  I've just upgraded initscripts to
initscripts-4.70-1 and that did not seem to help.
Comment 3 Ian Cameron 2000-01-16 10:22:59 EST
Further to my last comment, I have been poking around and traced the problem to
pump.  It is calling 'pump -r -i eth0' which causes the lock up.
Comment 4 Ian Cameron 2000-02-09 04:25:59 EST
I had a look at pump with gdb.  From (my bad) memory, I found that the problem
occurs in the daemon process after it has receieved a command via the socket.
The pump process issuing the command also dies after having written to the
socket on line 594 of pump.c.

Unfortunately I didn't get any further than this, as I never got around to
stopping pump from detaching from the terminal to debug the daemon process.

Hope this is useful.
Comment 5 Erik Troan 2000-02-13 09:19:59 EST
This may be fixed in pump-0.7.6, which you can get from
ftp://people.redhat.com/ewt/pump-0.7.6/. Please reopen this bug if you
continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.