Bug 743175 - Pacemaker blocks indefinitely when accessing /var/run/cluster/fenced_override
Pacemaker blocks indefinitely when accessing /var/run/cluster/fenced_override
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
: Rebase, TechPreview
Depends On:
Blocks: 747120
  Show dependency treegraph
 
Reported: 2011-10-04 00:00 EDT by Andrew Beekhof
Modified: 2012-04-03 05:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: pacemaker-1.1.6-2.el6
Doc Type: Technology Preview
Doc Text:
Under certain circumstances, an attempt to fence a node may have caused Pacemaker to stop responding when accessing the /var/run/cluster/fenced_override file. With this update, this error no longer occurs, and Pacemaker now works as expected in this scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 11:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Beekhof 2011-10-04 00:00:35 EDT
Description of problem:

When Pacemaker fences a node, it tries to let cman/fenced know.
However if /var/run/cluster/fenced_override is not yet open for reading, our call to open will block until it is.  This could be forever.

Version-Release number of selected component (if applicable):

pacemaker-1.1.5-8.el6

How reproducible:
Very

Steps to Reproduce:
1.  Configure a 7 node physical cman/pacemaker cluster
2.  Run CTS with fencing enabled
3.  Watch things blow up during the initial StartOnebyOne test
  
Actual results:
The cluster logs will contain messages that "cluster nodes failed to respond to the join offer" and "Welcome reply not received from".

Attaching to any of these nodes with gdb will show them blocked in tengine_stonith_notify() trying to open /var/run/cluster/fenced_override

Expected results:

The error logic is not triggered.

Additional info:
Comment 3 Lon Hohberger 2011-10-04 19:24:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The Pacemaker Cluster Resource Manager has been rebased to version [X] from upstream.  This includes fixes from the open source community.  Pacemaker continues to be offered as a Technology Preview.
Comment 6 Andrew Beekhof 2011-10-06 01:17:23 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The Pacemaker Cluster Resource Manager has been rebased to version [X] from upstream.  This includes fixes from the open source community.  Pacemaker continues to be offered as a Technology Preview.+The Pacemaker Cluster Resource Manager has been rebased to version 1.1.6 from upstream.  This includes fixes from the open source community.  Pacemaker continues to be offered as a Technology Preview.
Comment 9 Jaroslav Kortus 2011-10-17 11:12:43 EDT
solved (probably) by this patch: https://github.com/ClusterLabs/pacemaker/commit/cd2d55f68642c86afe157e836811aa0239c974c1
Comment 11 Jaromir Hradilek 2011-10-26 05:31:59 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The Pacemaker Cluster Resource Manager has been rebased to version 1.1.6 from upstream.  This includes fixes from the open source community.  Pacemaker continues to be offered as a Technology Preview.+Under certain circumstances, an attempt to fence a node may have caused Pacemaker to stop responding when accessing the /var/run/cluster/fenced_override file. With this update, this error no longer occurs, and Pacemaker now works as expected in this scenario.
Comment 16 errata-xmlrpc 2011-12-06 11:50:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1669.html

Note You need to log in before you can comment on or make changes to this bug.