Bug 74320 - Static routes cannot be added easily anymore
Static routes cannot be added easily anymore
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
All Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 75604 76619 82834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-20 08:28 EDT by Jos Vos
Modified: 2014-03-16 22:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-12 01:40:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2002-09-20 08:28:17 EDT
Description of Problem:
The ifup-routes scripts does *not* look at the network-scripts/route-$DEVICE
file anymore, *unless* a file networking/devices/$DEVICE.route exists.  This
makes it very difficult to easily add manual static routes by just putting them
in a file, like static-routes or route-$DEVICE.

Version-Release number of selected component (if applicable):
6.95-1

Workaround (only done a few tests):
Touch the networking/devices/$DEVICE.route, so that
network-scripts/route-$DEVICE is interpreted correctly.

Proposed fix:
Process the network-scripts/route-$DEVICE file before the
networking/devices/$DEVICE.route file is processed.
Comment 1 Bill Nottingham 2002-11-12 01:40:19 EST
*** Bug 76619 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2002-11-12 01:40:22 EST
*** Bug 75604 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2002-11-12 01:42:08 EST
Fixed in CVS, will be in 6.96-1
Comment 4 Bill Nottingham 2003-01-27 12:47:07 EST
*** Bug 82834 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.