Bug 743221 - Monitor->Graph does not display, throws an exception
Monitor->Graph does not display, throws an exception
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
: FutureFeature
Depends On:
Blocks: rhq42
  Show dependency treegraph
 
Reported: 2011-10-04 05:48 EDT by Heiko W. Rupp
Modified: 2012-02-07 14:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:22:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full stack trace (99.65 KB, text/plain)
2011-10-04 05:48 EDT, Heiko W. Rupp
no flags Details
Proposed patch (3.21 KB, text/plain)
2011-10-05 09:50 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2011-10-04 05:48:47 EDT
Created attachment 526215 [details]
Full stack trace

I was just trying to access metric graphs, but that fails with an exception page

Page shows:

	 IndexOutOfBoundsException
Index: 0, Size: 0
You can view the stack trace, return to the previous page, Dashboard, or Browse Resources page.

Stack trace then shows:

/rhq/common/monitor/events/data-plain.xhtml @53,56 test="#{not empty EventsTimelineUIBean.data}" Cant instantiate class: org.rhq.enterprise.gui.measurement.graphs.EventsTimelineUIBean.
com.sun.facelets.tag.TagAttributeException: /rhq/common/monitor/events/data-plain.xhtml @53,56 test="#{not empty EventsTimelineUIBean.data}" Cant instantiate class: org.rhq.enterprise.gui.measurement.graphs.EventsTimelineUIBean. at com.sun.facelets.tag.TagAttribute.getObject(TagAttribute.java:235) at 

Full trace is attached
Comment 1 Heiko W. Rupp 2011-10-04 05:56:49 EDT
Looks like this is not a general issue. I rather suspect (as I was looking at https://bugzilla.redhat.com/show_bug.cgi?id=634648 before) that the other issue may have caused this.
Comment 2 Heiko W. Rupp 2011-10-04 05:59:33 EDT
Indeed - my range preference were set to "advanced". Going to the tables tab also showed no data with the same trace in the logs.
Then at the bottom of the page I was able to set the time preferences to "last X" mode and set them to last 8 hours. After this the graphs displayed again correctly.
Comment 3 Heiko W. Rupp 2011-10-05 09:50:05 EDT
Created attachment 526496 [details]
Proposed patch
Comment 5 Heiko W. Rupp 2011-10-17 03:53:26 EDT
3e4e63a in master
Comment 6 Mike Foley 2011-10-18 10:59:20 EDT
identified new issue, discussed with heiko, and added new issue ... BZ https://bugzilla.redhat.com/show_bug.cgi?id=747007 

marking this verified
Comment 7 Mike Foley 2012-02-07 14:22:19 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.