Bug 743240 - F15->F16 yum update fails to boot new kernel
F15->F16 yum update fails to boot new kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-04 06:41 EDT by Jes Sorensen
Modified: 2011-10-09 15:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: dracut-013-15.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-09 15:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmsetup output (40 bytes, text/plain)
2011-10-04 06:42 EDT, Jes Sorensen
no flags Details
lvm lvdisplay (910 bytes, text/plain)
2011-10-04 06:44 EDT, Jes Sorensen
no flags Details
lvm pvdisplay (382 bytes, text/plain)
2011-10-04 06:44 EDT, Jes Sorensen
no flags Details
lvm vgdisplay (634 bytes, text/plain)
2011-10-04 06:45 EDT, Jes Sorensen
no flags Details
grub.conf (1.32 KB, text/plain)
2011-10-04 06:53 EDT, Jes Sorensen
no flags Details
mdadm.conf (186 bytes, text/plain)
2011-10-04 06:53 EDT, Jes Sorensen
no flags Details
/proc/mdstat (327 bytes, text/plain)
2011-10-04 06:54 EDT, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2011-10-04 06:41:18 EDT
Description of problem:
Did a fresh F15 install, then yum updated it to F16 Beta.
The install was done on /dev/sdc and no raid was involved, just
a straight disk on top of LVM.

After the yum update, grub boots the FC16 kernel, which then fails
in dracut not being able to find the root device.

Will attach log files

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Jes Sorensen 2011-10-04 06:42:48 EDT
Created attachment 526220 [details]
dmsetup output
Comment 4 Jes Sorensen 2011-10-04 06:44:06 EDT
Created attachment 526222 [details]
lvm lvdisplay
Comment 5 Jes Sorensen 2011-10-04 06:44:40 EDT
Created attachment 526223 [details]
lvm pvdisplay
Comment 6 Jes Sorensen 2011-10-04 06:45:05 EDT
Created attachment 526224 [details]
lvm vgdisplay
Comment 7 Jes Sorensen 2011-10-04 06:53:13 EDT
Created attachment 526227 [details]
grub.conf
Comment 8 Jes Sorensen 2011-10-04 06:53:47 EDT
Created attachment 526228 [details]
mdadm.conf
Comment 9 Jes Sorensen 2011-10-04 06:54:39 EDT
Created attachment 526229 [details]
/proc/mdstat

Note this was taken when system was booted into the F15 kernel
Comment 10 Fedora Update System 2011-10-04 08:47:28 EDT
dracut-013-15.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-15.fc16
Comment 11 Adam Williamson 2011-10-04 16:46:57 EDT
-1 blocker, yum upgrades are not part of the release criteria. if this is reproducible with an anaconda upgrade, I'd be +1.
Comment 12 Fedora Update System 2011-10-04 16:47:17 EDT
Package dracut-013-15.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-013-15.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/dracut-013-15.fc16
then log in and leave karma (feedback).
Comment 13 Kamil Páral 2011-10-06 09:08:30 EDT
I have taken a clean F15 install and upgraded to F16 + updates-testing (including dracut-013-15). I had to hard-reboot after upgrade, but system boots and looks ok. Bug fixed.
Comment 14 Adam Williamson 2011-10-07 13:39:23 EDT
kamil: the bug is system-specific, by the looks of it, it isn't just a general bug triggered by a yum update. so your test doesn't confirm the fix.
Comment 15 Adam Williamson 2011-10-07 13:40:36 EDT
Jens did confirm the fix in Bodhi, though:

"Solves BZ#743240 which I reported earlier! Thanks! "
Comment 16 Adam Williamson 2011-10-07 13:42:05 EDT
Discussed at 2011-10-07 blocker review meeting. In theory we need more information on the conditions needed to trigger this bug to evaluate its blocker status, but since in practice it'll likely be closed before the next blocker review, you probably don't need to bother giving us that.

(it seems to be something to do with having an mdraid array present, at least, as the fix is listed as "fixed mdraid container handling").
Comment 17 Fedora Update System 2011-10-09 15:39:07 EDT
dracut-013-15.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.