Bug 743249 - Provide a thread-safe version of the CFITSIO libray
Summary: Provide a thread-safe version of the CFITSIO libray
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cfitsio
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-04 11:13 UTC by Enrique
Modified: 2012-07-03 13:49 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-07-03 13:49:36 UTC


Attachments (Terms of Use)

Description Enrique 2011-10-04 11:13:55 UTC
Description of problem:

 The installed version in Fedora (at least as of F15) does not include support for a thread-safe environment. The support for multithreading applications can be enabled using the configure flag --enable-reentrant. However, even when compiled with that flag, the created shared library libcfitsio.so does not have a reference to libpthread.so:

ldd libcfitsio.so
        linux-vdso.so.1 =>  (0x00007fff5cce5000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f73d8e1d000)
        /lib64/ld-linux-x86-64.so.2 (0x00000035a0800000)

which makes applications to fail, unless explicitly stated compilation against -lpthread.
  To solve that, I propose the following patch:
diff cfitsio/Makefile.in cfitsio.new/Makefile.in
93c93
<               ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS}
---
>               ${SHLIB_LD} ${LDFLAGS} ${LIBS} -o $@ ${OBJECTS}

 Regards,
 Enrique

Comment 1 Sergio Pascual 2011-10-29 15:33:04 UTC
I have made a scratch build

http://koji.fedoraproject.org/koji/taskinfo?taskID=3471729

Please check that it works as intended.

Before sending this new version as an update, I'm going to check if packagers of dependent software find any problem using the multithreaded library.

Comment 2 Sergio Pascual 2012-07-03 13:49:16 UTC
Multithread is enabled since 3.280-2


Note You need to log in before you can comment on or make changes to this bug.