Bug 743386 - Ensure grub2 and grub-efi are both on the install media without making them 'default' in comps
Ensure grub2 and grub-efi are both on the install media without making them '...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 743376
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-04 14:28 EDT by Adam Williamson
Modified: 2011-10-29 02:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: spin-kickstarts-0.16.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 15:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-10-04 14:28:57 EDT
For F16, since anaconda will choose to install either grub2 or grub-efi depending on whether the install is EFI or BIOS, we need to ensure both packages are on the DVD and netinst images without making either one 'default' in comps (and hence having it installed when we don't want it).

I believe the way to do this would be to include both in the fedora-install-fedora.ks kickstart.

Proposing as an F16 blocker as this is required to ensure anaconda handles bootloader installation properly.
Comment 1 Adam Williamson 2011-10-04 14:32:07 EDT
depends on the existence of grub-efi, obviously.
Comment 2 Adam Williamson 2011-10-07 14:50:49 EDT
Discussed at 2011-10-07 blocker review meeting, accepted as a blocker per criterion "The installer must boot and run on systems using EFI other than Apple Macs".
Comment 3 Bruno Wolff III 2011-10-15 18:25:57 EDT
The changes to support this were committed to the spin-kickstarts repo.
Comment 4 Fedora Update System 2011-10-15 18:27:53 EDT
spin-kickstarts-0.16.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spin-kickstarts-0.16.2-1.fc16
Comment 5 Fedora Update System 2011-10-15 20:37:57 EDT
Package spin-kickstarts-0.16.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spin-kickstarts-0.16.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14428
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2011-10-20 15:24:19 EDT
TC1 DVD image, loopback mounted:

[root@adam temp]# find -name grub*
./Packages/grub-efi-0.97-83.fc16.x86_64.rpm
./Packages/grub2-1.99-9.fc16.x86_64.rpm
./Packages/grubby-8.3-1.fc16.x86_64.rpm
./isolinux/grub.conf

looks good to me!

closing because we don't use the packaged spin-kickstarts, we use git master directly (currently), so this is actually fixed already wrt image generation.
Comment 7 Fedora Update System 2011-10-21 00:46:39 EDT
spin-kickstarts-0.16.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spin-kickstarts-0.16.3-1.fc16
Comment 8 Fedora Update System 2011-10-24 21:50:57 EDT
spin-kickstarts-0.16.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spin-kickstarts-0.16.4-1.fc16
Comment 9 Fedora Update System 2011-10-29 02:32:12 EDT
spin-kickstarts-0.16.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.