Bug 74340 - After gnome logout Xcompletely crashes
After gnome logout Xcompletely crashes
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-20 15:21 EDT by David Kaplan
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-20 15:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2002-09-20 15:21:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0)

Description of problem:
I recently logged out of my X session for the first time in a while.  This
caused a complete crash in my X session and has prevented me from restarting X.
 I cant reboot for a bit as I have other processes running (all of which seem
fine), so there is still time perhaps to see what caused the crash before reboot
if someone can get on this right away.

I am running kernel-smp-2.4.18-10 on a dual athlon machine.  Kudzu identified my
video card as:

driver: Card:NVIDIA GeForce 2 GTS (generic)
desc: "nVidia Corporation|NV15 [GeForce2 Ti]"

I am using the NVdriver module (NVIDIA_kernel-1.0-2960), which has never caused
this before, but could be part of the problem (and wouldnt be your
responsibility), but I am not certain.  If it is, I will forward this bug to them.

Version-Release number of selected component (if applicable):
XFree86-4.2.0-8

How reproducible:
Didn't try

Steps to Reproduce:
1.log out of gnome session
2.
3.
	

Actual Results:  In /var/log/messages, I got the following logs:

Sep 19 16:35:48 erizo gdm(pam_unix)[2838]: session closed for user dmk
Sep 19 16:35:48 erizo gdm[2838]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
Sep 19 16:35:48 erizo gnome-name-server[8063]: input condition is: 0x11, exiting
Sep 19 16:35:48 erizo kernel: NVRM: AGPGART: freed 16 pages
Sep 19 16:35:48 erizo kernel: NVRM: AGPGART: backend released
Sep 19 16:35:48 erizo kernel: ------------[ cut here ]------------
Sep 19 16:35:48 erizo kernel: kernel BUG at page_alloc.c:135!
Sep 19 16:35:48 erizo kernel: invalid operand: 0000
Sep 19 16:35:48 erizo kernel: smbfs nls_iso8859-1 sg sr_mod emu10k1 sound
ac97_codec soundcore agpgart NVdri
Sep 19 16:35:48 erizo kernel: CPU:    0
Sep 19 16:35:48 erizo kernel: EIP:    0010:[<c0139680>]    Tainted: P 
Sep 19 16:35:48 erizo kernel: EFLAGS: 00013286
Sep 19 16:35:48 erizo kernel: 
Sep 19 16:35:48 erizo kernel: EIP is at __free_pages_ok [kernel] 0x130
(2.4.18-10smp)
Sep 19 16:35:48 erizo kernel: eax: 00000020   ebx: c15d7278   ecx: c02ef060  
edx: 0005c9a8
Sep 19 16:35:51 erizo kernel: esi: 00000000   edi: c1000030   ebp: 00000000  
esp: eeca9e90
Sep 19 16:35:51 erizo kernel: ds: 0018   es: 0018   ss: 0018
Sep 19 16:35:51 erizo kernel: Process X (pid: 2839, stackpage=eeca9000)
Sep 19 16:35:51 erizo kernel: Stack: c024472e 00000087 00000002 404ace38
f12b2d40 404ace38 f5d4f404 c012cf73 
Sep 19 16:35:51 erizo kernel:        f12b2d40 ffffffff 00008000 40029000
eebd70a4 c012b865 c15d7278 00008000 
Sep 19 16:35:51 erizo kernel:        00000001 00000000 00000000 40031000
f5d4f400 40029000 c037bfa0 00000000 
Sep 19 16:35:51 erizo kernel: Call Trace: [<c012cf73>] handle_mm_fault [kernel]
0xf3 
Sep 19 16:35:51 erizo kernel: [<c012b865>] do_zap_page_range [kernel] 0x205 
Sep 19 16:35:51 erizo kernel: [<c01177fd>] do_page_fault [kernel] 0x12d 
Sep 19 16:35:51 erizo kernel: [<c012beb0>] zap_page_range [kernel] 0x50 
Sep 19 16:35:51 erizo kernel: [<c012e5c1>] do_munmap [kernel] 0x201 
Sep 19 16:35:51 erizo kernel: [<c012e695>] sys_munmap [kernel] 0x35 
Sep 19 16:35:51 erizo kernel: [<c0108c5b>] system_call [kernel] 0x33 
Sep 19 16:35:51 erizo kernel: 
Sep 19 16:35:51 erizo kernel: 
Sep 19 16:35:51 erizo kernel: Code: 0f 0b 5f 5d c6 43 24 05 8b 43 18 89 f1 89 dd
83 e0 eb 89 43 

The XFree86.log.0 file at the time has been over written by one of my attempts
to get X going again, but I remember that it had a large number of messages
saying something like the hsync and vsync were bad.

The X crash has left a process [X] that cant be killed by any means.  

  root      2839  5.1  0.0     0    0 ?        RW   Sep02 1332:58 [X]



Expected Results:  gdm login screen

Additional info:
Comment 1 Mike A. Harris 2002-09-21 03:55:49 EDT
Unsupported driver.  Please contact Nvidia directly for support.

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.