Bug 74351 - anaconda unable to add partition to install redhat 7.2
anaconda unable to add partition to install redhat 7.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-20 23:22 EDT by pike_d
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump subsequent to the partition error (30.43 KB, text/plain)
2002-09-20 23:23 EDT, pike_d
no flags Details

  None (edit)
Description pike_d 2002-09-20 23:22:40 EDT
Description of Problem:
Basically I'm setting up my computer to dual boot win98 SE and redhat 7.2 on a 
40 gig drive.
I've used the 98 SE version of fdisk, from the cd, to make 1 primary DOS 
partition of 15 gig + 1 logical DOS drive of 15 gig. Both have been formatted 
to FAT32, and there is currently around 8gig of untouched, free space left on 
the HD.

Running through the redhat installer, it tells me the partition tables are 
inconsistent and gives me the option to "ignore" and go on, or "cancel" and 
initialize the disk. Ignoring it, I tell it to use the free space to create a 
linux partition, but it can't. It does recognise there's about 8 gig of free 
space there, but it won't add a linux partition or let me create my own.

I have tried this twice already, having used the "cancel" option to initialize 
the disk and then using linux fdisk option "o" to create a new, empty dos 
partition table, and then using 98 fdisk to start all over. I've used ranish 
partition manager to make sure there's nothing but free space on the disk, then 
tried again, but redhat always comes up with the same error about the partition 
table being inconsistent. It also says my disk is set to some 4865 cylinders, 
which it points out is greater than 1024, and may cause problems.

Version-Release number of selected component (if applicable):


How Reproducible:
Whenever I start all over from scratch, the same thing occurs.

Steps to Reproduce:
1. Use 98SE fdisk to remove all current dos partitions
2. re-create 1 primary partition + 1 extended partition -> logical drive
3. install win98SE and format both partitions to fat32
4. boot from redhat 7.2 cd and run through setup, where error occurs

Actual Results:
Redhat won't let me assign a linux partition

Expected Results:
Redhat should use the free space on the end of the disk to install it's root + 
swap partition, there's an easy 8 gig left there.

Additional Information:
Anaconda error log attached, as per it's recommendation.
Comment 1 pike_d 2002-09-20 23:23:51 EDT
Created attachment 76744 [details]
anaconda dump subsequent to the partition error
Comment 2 Jeremy Katz 2002-09-23 23:13:43 EDT
If you choose to manually partition, do you see the free space at the end of the
drive?  The traceback has been fixed in I think the update disk available on
ftp://updates.redhat.com and definitely in Red Hat Linux 7.3
Comment 3 Michael Fulbright 2002-10-24 14:21:21 EDT
Closing due to inactivity. Please reopen if you have any new information to add
to this report.
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.