Bug 743559 - Clicking on Group Definition Total value in Dashboard->Inventory Summary portlet displays globally uncaught exception
Clicking on Group Definition Total value in Dashboard->Inventory Summary port...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity medium (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: rhq41-ui rhq42
  Show dependency treegraph
 
Reported: 2011-10-05 07:28 EDT by Sunil Kondkar
Modified: 2012-02-07 14:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Exception (1.48 KB, text/plain)
2011-10-05 07:31 EDT, Sunil Kondkar
no flags Details
Exception_MessageCenter (1.67 KB, text/plain)
2011-10-10 08:16 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2011-10-05 07:28:30 EDT
Description of problem:

Navigated to the Dashboard->Inventory Summary portlet. It displays 'Group Definition Total' and a value next to it. Clicking on this value displays globally uncaught exception in UI.

Please find attached the exception details in message center.

Version-Release number of selected component (if applicable):
Build#466 (Version: 4.1.0-SNAPSHOT Build Number: 092d688)


How reproducible:
Always

Steps to Reproduce:

1. Login to RHQ.
2. Navigate to the Dashboard->Inventory Summary portlet.
3. Click on Group Definition Total value.
  
Actual results:

Clicking on Group Definition Total value in Dashboard->Inventory Summary portlet displays globally uncaught exception

Expected results:

No exception should be displayed

Additional info:
Comment 1 Sunil Kondkar 2011-10-05 07:31:41 EDT
Created attachment 526469 [details]
Exception
Comment 2 Sunil Kondkar 2011-10-05 07:36:42 EDT
Earlier tested with non-admin user with all resource permissions. However this is also reproducible with login as rhqadmin.
Comment 3 Heiko W. Rupp 2011-10-10 07:57:35 EDT
Can you still reproduce this? I saw that once too, but am not able to reproduce since.
Comment 4 Sunil Kondkar 2011-10-10 08:15:29 EDT
Tested and reproduced it on build#490 (Version: 4.1.0-SNAPSHOT Build Number: b67d2fa)

1. Logged in as rhqadmin and navigated to Dashboard->Inventory Summary portlet. Clicking on Group Definition Total value (0) displays globally uncaught exception in UI. 

(Details of exception in message center are attached)

2. Created a dynagroup definition and again clicked on the Group Definition Total value (1) in Dashboard->Inventory Summary portlet. It displays the globally uncaught exception in UI.
Comment 5 Sunil Kondkar 2011-10-10 08:16:22 EDT
Created attachment 527229 [details]
Exception_MessageCenter
Comment 6 Heiko W. Rupp 2011-10-10 08:46:24 EDT
5c787ba in master
Comment 7 Sunil Kondkar 2011-10-11 08:08:36 EDT
Verified on build#504 (Version: 4.1.0-SNAPSHOT Build Number: cf186c0)

Clicking on 'Group Definition Total' value in 'Dashboard->Inventory Summary portlet' navigates to the dynagroup definitions view. No exception is observed.

Marking as verified.
Comment 8 Mike Foley 2012-02-07 14:26:06 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.