Bug 74359 - regex (re_match) behavior changed
regex (re_match) behavior changed
Status: CLOSED DUPLICATE of bug 72312
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-09-21 13:53 EDT by Richard Hult
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-21 13:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Test case to show that re_match doesn't work correctly (1.10 KB, text/plain)
2002-09-21 13:54 EDT, Richard Hult
no flags Details

  None (edit)
Description Richard Hult 2002-09-21 13:53:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
re_match doesn't seem to return the offset of the match from start, but from the
start of the entire string, which it did in rhl 7.3, and which also is the
documented behavior in regex.h

Version-Release number of selected component (if applicable):

How reproducible:

I'll attach a test case.
Comment 1 Richard Hult 2002-09-21 13:54:57 EDT
Created attachment 76787 [details]
Test case to show that re_match doesn't work correctly
Comment 2 Jakub Jelinek 2002-09-21 13:59:16 EDT
This has been fixed already. See http://sources.redhat.com/ml/libc-hacker/2002-08/msg00152.html
You need glibc >= 2.2.90-27.

*** This bug has been marked as a duplicate of 72312 ***
Comment 3 Richard Hult 2002-09-21 14:19:45 EDT
Oh, I didn't find the bug when I searched. Thanks for the quick answer and great

Note You need to log in before you can comment on or make changes to this bug.