This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 743792 - Some Book Titles on docs.redhat.com (and docs-stage) are not alpha-sorted.
Some Book Titles on docs.redhat.com (and docs-stage) are not alpha-sorted.
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
i386 Linux
unspecified Severity low
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 23:14 EDT by Jared MORGAN
Modified: 2015-08-09 21:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2011-10-05 23:14:52 EDT
Description of problem:

If books have upper-case letter strings in the start of the book title, the book is being incorrectly alpha-sorted on the hosting and live docs sites.


Version-Release number of selected component (if applicable):

Publican 2.8


How reproducible:

100%


Steps to Reproduce:
1. Navigate to docs.redhat.com
2. Click JBoss Enterprise Application Platform > 5 in the navigation tree
3. Note the order of book titles.
  
Actual results:

HTTP Connectors Load Balancing Guide appears *before* Hibernate guides.

RESTEasy Reference Guide appears *before* Release Notes


Expected results:

HTTP Connectors Load Balancing Guide appears *after* HornetQ User Guide

RESTEasy Reference Guide appears *after* Release Notes 5.1.1


Additional info:

This also affects docs-stage. It is not just EAP that is affected. Red Hat Enterprise Linux > 6 > DM Multipath is also out of alpha-order.

I spoke to Rudi about this, and he added the following info:

(13:03:45) rudi: Looks like Publican is sorting those titles according to Unicode codepoint

Hope this helps in fixing the issue.
Comment 1 Jeff Fearn 2011-10-10 06:44:22 EDT
Made string comparison of Product and Book Name case insensitive.

Applied to branch/publican-2x and trunk.

Committed revision 1906.
Comment 2 Jared MORGAN 2012-02-16 20:07:59 EST
I've checked docs.redhat.com, and this issue no longer presents. I think you're good to close this off, Jeff.

Note You need to log in before you can comment on or make changes to this bug.