Bug 7438 - Network disconnects
Network disconnects
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 05:25 EST by Viktor Steinmann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 13:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Steinmann 1999-11-30 05:25:44 EST
The machine is working fine. After some time (2-3 days) the machine cannot
be reached over the network anymore. No ping, no telnet, no ssh. Now the
funny part: After logging into the machine by the console, the network
connection is restored immediately.

APM features in the BIOS are turned off (that was my first guess). But
unfortunately this did not help.

It's a TYAN S1836DLUAN Thunder 100 Mainboard, which is equipped with a
Intel 82558 10/100 Ethernet-Controller.
Comment 1 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 2 adam 2000-07-09 21:41:15 EDT
I'm getting this problem almost exactly, except it's version 6.2.  (Hmmmm, I
wonder if it's the same thing?  Maybe I should post a new bug...) The difference
is that the server's keyboard is not physically accessable to me, as it is
co-located.  Here's the trick: if I log into one of the other co-located
machines at the same site, I can then ssh from that box to the screwed-up box
over the LAN!  Then if I type "ping <machine on internet>" the network
connection is restored for a few minutes, until it disappears again.

My temporary fix is to have "ping yahoo.com > /dev/null &" running at all times.
Comment 3 Alan Cox 2000-08-08 13:39:40 EDT
The first report looks like the a known problem with the intel stuff that should
be mostly fixed in 2.2.16 but not 100% of cases. Please try the update kernel
and let m eknow

The second is the classic misconfigured bridge (probably 3com) which is not set
to broadcast frames to an unknown mac address but instead drop them. 
Comment 4 Alan Cox 2000-09-23 18:31:21 EDT
Believed fixed in 6.2 errata kernel.
Other problem appears to be non Linux
Comment 5 giuliano 2000-11-29 04:06:51 EST
Hi.

I have same problem with network on a RedHat 6.0 2.2.5-22.
Sometimes networks disconnects misteriously, and i have to reboot the
machine.....
With new 2.2.16-3 upgrade the problem was fixed?

Note You need to log in before you can comment on or make changes to this bug.