This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 743823 - implement alternate guest uuid upload method
implement alternate guest uuid upload method
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.2
Unspecified Unspecified
high Severity unspecified
: rc
: 6.2
Assigned To: Radek Novacek
John Sefler
:
Depends On: 737935
Blocks: rhsm-rhel62 747120
  Show dependency treegraph
 
Reported: 2011-10-06 04:17 EDT by Radek Novacek
Modified: 2011-12-06 13:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 737935
: 749514 (view as bug list)
Environment:
Last Closed: 2011-12-06 13:56:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 Radek Novacek 2011-10-10 11:28:48 EDT
Fix for this issue has already been applied upstream:
https://fedorahosted.org/virt-who/changeset/8ccfc5ec3006f4fee71e549217a4d335163aded6

The test for this bug is to check if steps related to virt-who from the testplan succeeds: 
https://riddler.bne.redhat.com/IEEE_Test_Plans/en-US/RHEL/6.2/html-single/Entitlement-Subscription_IEEE_Test_Plan/index.html
Comment 8 Keqin Hong 2011-10-13 09:49:26 EDT
Verified on virt-who-0.3-3.el6.noarch, the new design works.

# vi /etc/sysconfig/virt-who
VIRTWHO_BACKGROUND=1 (enable debugging)
VIRTWHO_DEBUG=1 (run in background)   

# service virt-who restart
Virtual machine found: 1005.1-s-64: 063a46e5-1e50-81e5-9ae4-94f45f41d79e
Virtual machine found: 1005.1-s-64-clone: d2464bf3-b0c4-e2f7-1462-31f2ca63706b
Sending update to updateConsumer: ['063a46e5-1e50-81e5-9ae4-94f45f41d79e', 'd2464bf3-b0c4-e2f7-1462-31f2ca63706b']
Comment 10 errata-xmlrpc 2011-12-06 13:56:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1757.html

Note You need to log in before you can comment on or make changes to this bug.