This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 743868 - /bin/sh: /etc/rc.d/init.d/dhcpd: No such file or directory
/bin/sh: /etc/rc.d/init.d/dhcpd: No such file or directory
Status: CLOSED DUPLICATE of bug 709151
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 06:52 EDT by Kamil Páral
Modified: 2012-04-16 22:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 22:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2011-10-06 06:52:41 EDT
Description of problem:
I installed cobbler and set manage_dhcp to 1. I installed dhcp package. When running "cobbler sync":

running post-sync triggers
running python triggers from /var/lib/cobbler/triggers/sync/post/*
running python trigger cobbler.modules.sync_post_restart_services
running: dhcpd -t -q
received on stdout: 
received on stderr: 
running: /etc/rc.d/init.d/dhcpd restart
received on stdout: 
received on stderr: /bin/sh: /etc/rc.d/init.d/dhcpd: No such file or directory

Exception occured: <class 'cobbler.cexceptions.CX'>
Exception value: 'cobbler trigger failed: cobbler.modules.sync_post_restart_services'
Exception Info:
  File "/usr/lib/python2.7/site-packages/cobbler/remote.py", line 95, in run
    rc = self._run(self)
   File "/usr/lib/python2.7/site-packages/cobbler/remote.py", line 184, in runner
    return self.remote.api.sync(self.options.get("verbose",False),logger=self.logger)
   File "/usr/lib/python2.7/site-packages/cobbler/api.py", line 611, in sync
    return sync.run()
   File "/usr/lib/python2.7/site-packages/cobbler/action_sync.py", line 146, in run
    utils.run_triggers(self.api, None, "/var/lib/cobbler/triggers/sync/post/*", logger=self.logger)
   File "/usr/lib/python2.7/site-packages/cobbler/utils.py", line 862, in run_triggers
    raise CX("cobbler trigger failed: %s" % m.__name__)

!!! TASK FAILED !!!


The dhcp package doesn't contain sysvinit scripts anymore, it contains native systemd unit files.

Version-Release number of selected component (if applicable):
cobbler-2.0.11-2.fc15.noarch
dhcp-4.2.1-11.P1.fc15.x86_64
Comment 1 Peter Hinse 2011-11-12 17:43:25 EST
Same here with F16 and cobbler-2.0.11-3.fc16.noarch. Switching to Dnsmasq for dhcp and dns does not help, no sysvinit scripts there too.
Comment 2 Alan Crosswell 2012-02-12 10:53:53 EST
This is a dupe of bug 709151
Comment 3 Fedora Admin XMLRPC Client 2012-04-11 18:00:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 James C. 2012-04-16 22:17:29 EDT

*** This bug has been marked as a duplicate of bug 709151 ***

Note You need to log in before you can comment on or make changes to this bug.