Bug 74387 - Install hangs at Installing Packages
Install hangs at Installing Packages
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-09-22 22:32 EDT by Bill Peck
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2002-09-22 22:32:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
Null fails to install on my Athlon XP2200+ machine.  I answer all the questions
in the installer.  Gets to the screen where it has the progress bar (Installing
RedHat).  Hard drive makes a quick noise and then nothing.  sits here forever. 
Switching to console 4 shows the HDA partitions (sometimes it doesn't even show
that). console 5 and 6 show nothing. I don't think its formating the hard drive.

Installing RH7.3 on the same machine works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Beta Null on XP2200+ with IDE harddrive

Actual Results:  System was responsive but installer hung.

I also tried running hdparam -I /dev/hda from console 2 and that just hung.

Expected Results:  Install should begin..  drive should format

Additional info:
Comment 1 Bill Peck 2002-09-22 22:44:17 EDT
Just noticed that when I do a ps auxww on console 2 I see mkswap running and its

Comment 2 Need Real Name 2002-09-23 09:38:38 EDT
I have also experienced this problem, while trying to install on my Athlon 
1600+ and also on my Athlon 1800+. In both cases, the install seemed to hang, 
either during the format of the drive, both machines have IDE drives. other 
times, it hangs while installing packages.  Only on an Intel system, have I 
been successful in installing NULL.
Comment 3 Michael Fulbright 2002-09-23 16:41:15 EDT
Any interesting errors on VC4?
Comment 4 Bill Peck 2002-09-23 19:44:52 EDT
The last two messages on Console 4 are:

<6> cdrom: open failed
<6> hda: hda1 hda2 hda3

I am installing via nfs so there is no cdrom in the drive.  At this point the
hard drive light is on solid.  I was able to run the hdparm -I /dev/hda command
before I got to this point in the install (actually right after I partitioned
the disk), but now with mkswap /dev/hda3 being defunct when I run hdparm now it
just prints hda and hangs.

Strange thing is I was able to install on a different hard drive (much older
drive, 4.3 GB) but the bios didn't see the drive so I couldn't boot.

This is an Asus A7V333 motherboard with bios 1008.

Like I said this same setup works with RH 7.3
Comment 5 Bill Peck 2002-09-23 20:04:33 EDT

link to the drive that Null fails to install on.
Comment 6 Michael Fulbright 2002-10-02 15:56:49 EDT
Appears to be a kernel driver related issue.
Comment 7 Bugzilla owner 2004-09-30 11:39:56 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.