Bug 7439 - New kernel detects the version wrong when upgrading.
New kernel detects the version wrong when upgrading.
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 05:36 EST by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-06 00:57:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 1999-11-30 05:36:08 EST
I'm using a Redhat 6.0 kernel (2.2.5-22), and when I try to upgrade
to the newest 2.2.13-0.4 from Rawhide, I get the following conflicts:
----
error: failed dependencies:
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
----

This is obviously wrong, since the kernel being upgraded is 2.2.5, not
2.0*.

I didn't test if e.g. stock RH6.1 kernel has the same problems.
Comment 1 Bill Nottingham 1999-11-30 11:17:59 EST
Make sure you grab the latest rpm RPM.
Comment 2 Pekka Savola 1999-11-30 12:38:59 EST
I think not - see bug #7446.
Comment 3 maavl 1999-12-01 10:08:59 EST
I think the problem might not be the absence of a sufficiently new kernel, but
the presence of an old one; after all you're getting conflicts, not failing
dependencies. See if you have old kernel packages hanging around, and if so,
uninstall them; I needed to do this once too, after which I could install the
latest initscripts. Don't forget to remove the uninstalled kernel from lilo.conf
and to rerun lilo. Once you have upgraded the initscripts, the old kernel would
be quite useless anyway (I tried this). You may want to upgrade some other core
utilities together with initscripts as well, even if not required by a
dependency, for instance modutils (see bug 7343); a mix of new and old stuff has
not always been well tested at RedHat.
Comment 4 Bill Nottingham 1999-12-01 11:35:59 EST
Oh, by 'latest' rpm I meant 'latest stable'; the one that
shipped with 6.1 should suffice.
Comment 5 Cristian Gafton 2000-01-04 17:25:59 EST
Assigned to dledford
Comment 6 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford

Note You need to log in before you can comment on or make changes to this bug.