Bug 744004 - CLI script examples references unknown external function
CLI script examples references unknown external function
Status: CLOSED DUPLICATE of bug 738063
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Deon Ballard
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 14:03 EDT by Mike Foley
Modified: 2011-10-24 11:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 11:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
CLI script (2.34 KB, text/javascript)
2011-10-06 14:03 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-10-06 14:03:33 EDT
Created attachment 526764 [details]
CLI script

Description of problem:  CLI script examples references unknown external function


http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/2.4/html/CLI_Guide/Scripted_Group_Deployments_using_the_CLI_API.html

at lines 1, 11, 16, 29, and 51 ... the example script references an unknown external function named usage();  


Actual results:
Exception in thread "main" org.rhq.enterprise.client.script.CLIScriptException: javax.script.ScriptException: sun.org.mozilla.javascript.EcmaError: ReferenceError: "usage" is not defined. (<Unknown source>#29) in <Unknown source> at line number 29


Expected results:
example script works.  

Additional info:
attachments
Comment 1 Deon Ballard 2011-10-12 21:16:41 EDT
Hmm. I could have sworn that this example was on the RHQ wiki, but I cannot find it. I can find and article on the JBoss wiki (http://community.jboss.org/wiki/JON23ScriptedGroupDeploymentsUsingTheCLIAPI), but I don't recognize the author.

I'll check the example scripts in the source and see what I come up with.
Comment 2 Deon Ballard 2011-10-24 11:03:23 EDT

*** This bug has been marked as a duplicate of bug 738063 ***

Note You need to log in before you can comment on or make changes to this bug.