Bug 744009 - mumble needs rebuild to support the new protobuf-devel in f16
mumble needs rebuild to support the new protobuf-devel in f16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mumble (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Andreas Osowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 14:17 EDT by Ben Williams
Modified: 2011-11-23 18:27 EST (History)
4 users (show)

See Also:
Fixed In Version: mumble-1.2.3-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-23 18:27:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Williams 2011-10-06 14:17:57 EDT
Description of problem:

Installing mumble in f16 says missing dep of libproto.so.6

Version-Release number of selected component (if applicable):


How reproducible:

always 
Steps to Reproduce:
1.yum install mumble
2.
3.
  
Actual results:
    Loaded plugins: langpacks, presto, refresh-packagekit
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package mumble.x86_64 0:1.2.3-3.fc15 will be installed
    --> Processing Dependency: celt071 for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libprotobuf.so.6()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libdns_sd.so.1()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtOpenGL.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtDBus.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtXml.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtSql.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtSvg.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtCore.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtGui.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Processing Dependency: libQtNetwork.so.4()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    --> Running transaction check
    ---> Package avahi-compat-libdns_sd.x86_64 0:0.6.30-4.fc16 will be installed
    ---> Package celt071.x86_64 0:0.7.1-2.fc16 will be installed
    ---> Package mumble.x86_64 0:1.2.3-3.fc15 will be installed
    --> Processing Dependency: libprotobuf.so.6()(64bit) for package: mumble-1.2.3-3.fc15.x86_64
    ---> Package qt.x86_64 1:4.8.0-0.12.20111002.fc16 will be installed
    ---> Package qt-x11.x86_64 1:4.8.0-0.12.20111002.fc16 will be installed
    --> Finished Dependency Resolution
    Error: Package: mumble-1.2.3-3.fc15.x86_64 (fedora)
    Requires: libprotobuf.so.6()(64bit)
    You could try using --skip-broken to work around the problem



Expected results:
install with all deps

Additional info:
protobuf-devel in f16 has been updated and does not have libprotobuf.so.6 any longer
Comment 1 Florent Le Coz 2011-10-10 21:32:32 EDT
mumble-1.2.3 package needs to be edited a little in order to build properly on f16.
I added a patch to fix the include of celt (must be celt071/, not just celt/), and changed the other patch to reflect the correct Ice version.

See the koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=3420568

I use personally use mumble, and that package works for me.
Comment 2 Sylvain Réault 2011-10-26 10:03:04 EDT
Where is .src.rpm for package build please?

It's not available on koji.

This is a problem given the upcoming release of Fedora 16 stable.
Comment 3 Florent Le Coz 2011-10-26 10:37:06 EDT
Oh, I thought koji was providing a link to the .src.rpm whenever you build a package on it.

Here it is http://louizatakk.fedorapeople.org/rpm/mumble-1.2.3-4.fc16.src.rpm

Testing this package would be appreciated and would help making mumble available on fedora 16, if it’s maintainer ever responds.
Comment 4 Fedora Update System 2011-11-09 19:24:01 EST
mumble-1.2.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mumble-1.2.3-5.fc16
Comment 5 Fedora Update System 2011-11-10 12:51:35 EST
Package mumble-1.2.3-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mumble-1.2.3-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15710
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-11-23 18:27:14 EST
mumble-1.2.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.