Bug 744054 - Cannot install to MBR of an Intel BIOS RAID-0 array (Sony Vaio Z stock layout)
Cannot install to MBR of an Intel BIOS RAID-0 array (Sony Vaio Z stock layout)
Status: CLOSED DUPLICATE of bug 743273
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-06 16:38 EDT by Adam Williamson
Modified: 2011-10-14 13:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-14 13:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from console commands and grub2.cfg contents (9.16 KB, text/plain)
2011-10-06 16:38 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-10-06 16:38:30 EDT
Created attachment 526794 [details]
output from console commands and grub2.cfg contents

My laptop's a Sony Vaio Z 2010 model, which comes from the factory with two SSDs configured as a BIOS RAID-0 array (yes. really, it does.)

F14 and F15 are happy with this setup, installing grub onto the MBR without any trouble. grub2 is not so happy with it. I rebuilt grub2-1.99-6 for f15, installed it, did 'grub2-mkconfig -o /boot/grub2/grub.conf' and 'grub2-install /dev/md127' (the RAID array device), and it failed. grub2-mkconfig completed but complained a bit, grub2-install fails. Attaching all relevant output. Proposing as F16 blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above".
Comment 1 Adam Williamson 2011-10-07 14:32:00 EDT
Discussed at 2011-10-07 blocker review meeting. Again this is a grub2/raid issue which needs some evaluation by pjones. It may also be a dupe of #743273.
Comment 2 Adam Williamson 2011-10-14 13:50:13 EDT

*** This bug has been marked as a duplicate of bug 743273 ***

Note You need to log in before you can comment on or make changes to this bug.